WD MyBook 4TB is recognized but I cant explore the files in any OS

main system info:
OS Name: Microsoft Windows 7 Home Premium
OS Version: 6.1.7601 Service Pack 1 Build 7601
System Manufacturer: MSI
System Model: MS-7994 (H110 Gaming)
System Type: x64-based PC
Processor(s): 6th Gen Intel Core i5 6402P 2.8GHz
RAM: 16GB 2400MHz DDR4
BIOS Version: American Megatrends Inc. 5.A0, 12/7/2017

I have had this product with P/N: WDBFJK0040HBK-0A for 4 years and have never dropped or mistreated it. I have always safely removed it from the PC and never had any issues until I opened the contents in my ubuntu VirtualBox and then made a big boo boo.

Ok so I had Ubuntu and Windows 7 dual boot on my machine. I had all the WD utilities and drivers installed and the security features like the WD Unlock. It was encrypted with WD unlock and I know the password I had.

What happened was while I was in windows and in a virtual box, trying out Ubuntu 18.04LTS before a physical install, I plugged in the MyBook and explored the drive in the virtual box. Upon liking the 18.04 experience, I shut down my machine and inserted my bootable USB to upgrade my 2nd harddrives’ Ubuntu version to the new one.

(I learned a lot over the last few weeks)
Being a Noob at partitioning, I accidentally installed over my windows boot record or whatever and when I tried to get into my windows drive, I was greeted with the awesome Grub Rescue error.

I kinda freaked out since this is my main 3D modeling and gaming rig (TES:IV modding is the only reason I have windows) and windows was kinda… gone.

So thinking it was all good because EVERYTHING important was backed up to the 4TB drive, I figured I’d just reinstall windows, so I did.

Well after that, while my external drive was plugged in to the machine, I noticed the first thing that happened after all the updates and stuff was that I had a driver not installed right and it was my MYBook drive. I was greeted with a prompt to get the SES Drivers for the device. I downloaded all the necessary drivers for the drive as well as attempted to update the drivers through windows update. I also ran WD diagnostic tools and SMART scan, it all came back healthy and passed.

At this point the drive would show up in device manager and reported to all be working properly, drivers installed and everything. But still couldnt explore the drive. So went to diskmanagement to try and assign a drive letter to it thinking that was the issue. I see no option to assign a drive letter so that did not work. In fact all I saw in disk management was option to make it dynamic disk. (Dont know what that is but it sounds like my disk is running away from me so forget that) In disk management It shows up as 3 healthy partitions. I dont remember if it was 3 partitions beforehand.

So it seems to spin up, seems like it’s going to work, but in My Computer, there is no drive and Windows seems to think its all working fine.

I decided to try it in another computer system so I plugged it into my daughters LinuxMint computer (which has saved me so many times from weird stuff like this with windows drives). In Linux, on several distros, it did the same thing as it did in all the Linux distros I tried: Ubuntu 16, 18.04, Debian 9.5 , Linux Mint 18, & 19

In all OS’s I see the drive in the disk utility in Linux, It shows as an encrypted LUKS drive or something. Then asks for the password to view the contents of the drive. I know the password I made, but I think the problem is that its the password I used with the WD Unlock encryption software that was installed on my previous install of windows 7. I dont know…

SO no avail. Linux claimed incorrect passphrase

Now I’m freaking out because I lost over 10years of family photos and memories of my kids and fun we had together. I’m very sad. I’ve been up for days trying to learn everything I can to access my data. I am currently unemployed and cant afford even the programs online such as the one below, that claim to save your files if you purchase a license.

What I was able to do was install Easy PhotoResQ from this website http://www.easyphotoresq.com/download.html and I have been given a glimpse of hope. After a 2 day scan of the drive for all files, I can preview all of my lost files on the external drive with the software. I cannot “rescue” the files unless I pay for the program which is only $30 but like I said, I’m a single father with no income and child support and I live with my parents who a graceful enough to let me live here, use their utilities, internet and all. (Yes I look for a job all day and Im learning Linux, HTML5, CSS, and Python to try and change careers. I live in Stockton, CA. Its not the nicest place to be as far as anything goes, in fact, going outside is a serious risk to your life in my neighborhood)

Anyways the point is that I am able to view the contents of the drive with this software only; but I cant buy it right now, hopefully soon, but even if I do, who knows if it will actually be able to save my files.

Has anyone had this issue? Is there anyone that can help me out? Im just a father trying to save memories of his children and family members who are no longer with us. I was working on a montage of memories and that file is also on the drive.

I dont have receipt for the purchase of the drive because I bought it at best buy years ago and I dont think I want to RMA it since this thing is the only device in the universe left with my memories on it and thats a huge risk.

sorry this was so long and thank you so much for your time.
Godspeed
-Pastlife
Starseed-PL