8TB My Book "Location is not available"

Just purchased an 8TB My Book. Attached it and added a password but did not select “Enable auto unlock for this computer”. I moved a few files back and forth to test the drive and everything was fine until I rebooted the machine.

The drive now shows up and gets assigned a letter but is not accessible. After unlocking it with the WD Security tool, Windows (v7) informs me the drive must be formatted before it can be used. After declining this, clicking on the drive to open it in File Explorer results in a modal dialogue saying the location is not available. I ran the WD utilities “Quick Drive Test” and no issues were detected. The “Complete Drive Test” is running now and has progressed, so I’m assuming it can access the drive.

After unlocking the drive, I tried scanning new hardware in Device Manager. I also tried to populate the volume list box in the drive’s property dialogue (it closes the dialogue with no message - just poof and it is gone). I can see it in Disk Management and have tried re-assigning the drive letter to force Windows to re-look at the drive, but the result is the same.

Windows and drivers are up to date. Thought I’d ask here before opening a ticket. Any ideas? Thanks.

Update (4/9/2016):
I removed the password, unplugged the drive and rebooted the machine, thinking that might solve the problem of access. My machine wouldn’t reboot. Kept getting a “Reboot and select proper boot device” error, so I checked the BIOS and somehow a drive called “WD …” was first in line for booting.

Say what?!?!

Somehow, Western Digital’s drive utilities saw a different WD drive (a Passport USB portable drive I used to move work files between computers) and tried to stick a boot record or something on it. I’m assuming I had my BIOS set up to have a USB thumb drive as the first boot sequence slot and whatever WD’s utilities did to my Passport made it look like a bootable thumb drive. That’s the only thing I can think of that makes any sense.

Anyway, I pulled the plug on the Passport and rebooted and was able to get the machine up. I booted again and checked the BIOS, the first slot was now for a removable USB device.

I’ve booted this box a hundred times with that Passport drive plugged into it and that never happened before. It must have been the WD utilities making changes without asking me.

Gah, what a waste of a Saturday. And the irony is the worst - the WD “solution” for backing up my files corrupts my machine so it won’t boot, thus creating the very situation it is intended to mitigate.


Hi, where you able to fix the problem with the My Book?

Sadly, not yet. After the reboot, the drive is still not accessible and Windows continues to ask me if I want to format it. I’ve since added and removed the password several times but no luck, so I opened a service ticket. If I get a resolution I’ll post it back here (though I am sensing an RMA in my near future…). I was going to try removing and re-adding SES but thought it best to wait for someone from WD to take a look.

Hello, did you try in a different computer and with different USB cable?

Yes, I tried it in a Lenovo laptop and it did not recognize it. Again, it shows up in Disk Manager and has a health partition, but it can’t be accessed. HP responded and told me to re-partition and format the drive. That pretty much kills my confidence in this hardware.

I have the same issue. Windows Admin Tools computer Manager ==> Storage sees the drive and tells me it’s healthy and active. I tried a desktop (HP) and my laptop (DELL) and both agree. I also have a smaller Seagate driver with the same problem. Any news/updates/suggestions?