My Book not showing up as a drive on my pc any more

I had to open up my tower to tighten my graphics card so I disconnected everything before doing so and when I hooked it all back up, I started having issues with the my book.  I have another fantom ED that didn’t give any problems also.  At first, “my book” showed up under my computer it just showed as empty.  If I check the properties on it tho, it showed only 300mb free of 1tb which is accurate, so I know the files were not completely lost.  I checked to make sure that all hidden folders were showing and that wasnt the problem.  I tried running the smartware but that also showed nothing on the my book drive.  Then I rebooted my computer and “my book” no longer shows as a drive at all when I open “my computer”.  I downloaded some data recovery program but I cant even access the my book drive with it any more.  I tried reconnecting the power and usb cables but I am not having any luck.  I just need my computer to recognize this my book as a drive, any help here would be greatly appreciated.  Thanks in advance!

Bump for help please!!

Does the disk do the same thing on a totally different computer?

Having same issue.  was attached to my router and working fine then it locked up while i was renaming a file.  will not work on any desktop or laptop in the house (we have 3 of each).   usb drivers will load but cannot browse the drive and WD quick diag says no problems but full scan cannot repair.  

Am a grad student with all my course work on drive. please help.

Well, it might be a logical recovery that’s needed.

1st thing I’d do is backup/image the drive… and then run something like R-studio or GetDataBack or Ontrack Easy Recovery Pro.

IF WD diagnostic says there is no probem. Then what’s with the full scan finding errors it can’t repair?

Senseless to back up, if you can’t even access the drive at all…

IT CANNOT BE ACCESSED. Means: it was in the list in one minute, in the next it was no longer in the drive’s list.

Nothing works.

Instead it shows up like “My Book”  working fine… And working fine means: according to the PC it works fine. No driver update needed etc. Not that it could be accessed as a drive!

After 10 minutes it is invisible, restarding, and appears as “unknown device” or “Initio Default Controller” …

How to deal with a drive that is an Initio Default Controller??

The disk may be able to be imaged from a linux disk. This is a safety precaution when working with important data. A pro service would do this. And perhaps the OP should send the disk to a pro service for recovery.

I do not have Linux. I have ONE PC and not two.

I am a private end user. I expect hardware to run and not to simply disappear.

Sorry that I took kaind of over this thread. But I have exactly the same problem.

Are we saying the disk is not visible in device manager? Or disk management? Or windows explorer? All 3?

Does a Linux boot disk (with utilities) such as Hiren’s Boot CD see this disk? You can download that and test it out. You don’t need to install anything. just boot from it.

The disk (formerly R drive for more than a year) appears as a drive NOT accessable by any means. Whatever you would do it will fail.

It then -after 10 minutes or so - disappears, restarts and appears as an unknown device.


In the disk manager it appears as a mass storage device / not initiated/. Not accessible…

In the USBDeview (a program which shows me any machine connected to a USB at any time in the life of the computer), it shows ‘WD’ … you can see there is no letter assigned. Doing it manually is not possible. I can see the SERIAL NUMBER box filled with 20202020202020 etc. which must be a part of the error.

Please give me the link to that tool you named. It MUST run on WINDOWS 7… Thanks!

I found the website. But website? And where to download it?

A boot disc does not run on windows 7. It is a temporary o/s replacement that runs entirely from cd. The purpose here is to run the mini windows xp to see if your disk can be detected that way.

The purpose here is to see if your disk is detected reliably outside of the installed o/s, and if the cables and power and drivers are operational. We’re narrowing down the cause.

Don’t go running anything you don’t understand, because you’ll probably do more damage.

Well there is only one program that gets the disk … and  that is “Partition Recovery”.

But it denies any kind of recovery telling:


I guess the program cannot  open the disk either.

I have been working with computers and disks - also on Hotlines - for 25 years now.

I need the help from WD. And I need it soon. As there are very important data on the disk which I cannot otherwise recover.

Cable is OK, USB checked on all interfaces … It is simply a kind of wall …

And the fact that it is an INITIO DEFAULT CONTROLL …  after a while.

This is sounding more and more like an encryption chip failure or drive firmware issue. You can either wait for WD to respond here, if they do. Or contact them at their customer support. I doubt WD is going to be of much assistance, their troubleshooting goes little beyond cables and power adapters and RMA’ing defective products, unless you get to a higher tier; and even then.

Assuming all the basics are taken care of this would be a job for a pro service. I’ve been working with disks for 20 years and basically they either work or they do not. Since you have important data on it it’s best to let a pro service that knows what they’re doing work on it in person.

Some things on google say this is a power related issue, that the encryption chip is not operating stably due to low power. I’ve only observed this a few times in many years of fixing these. Heck it could even be dirty/stale contacts between the drive and the bridgeboard. Who knows??

One thing is sure… I googled a lot, too, before I entered this forum. I still have hope, that this problem can be solved. As I live in Europe, I somehow hope that they see what is going on here.

It is not a power-related issue. I tried everything from A to Z.

I’m hoping someone will comment on this, because, the only thing I see here is a communications failure between the computer and the initio bridge chip. And the problem is probably on the bridgeboard side of things.

One reason that the bridge IC may identify itself as a Default Initio Controller is if it cannot detect its flash memory chip, or if the firmware in this chip is corrupted. This sometimes happens after a failed firmware update. I have also seen this happen on Seagate’s forums, but in those cases it is caused by insufficent power, usually in port powered models.

I believe that the bridge IC may also identify itself this way if it cannot detect a HDD behind the bridge.

I don’t know if Microsoft’s UVCView utility can provide any helpful information, but it might be worth having a look:

BTW, as a general rule, a bridge chip will have its own internal Product and Vendor IDs, in this case Initio’s. An OEM manufacturer, such as WD, may choose to have the device report the OEM’s Product and Vendor IDs, in which case this information is programmed into the external serial flash memory.

Thank you for the reply. Well the device has its own power cable, it is not only port powered.

Is the chip you are talking about replaceable?

The WD drives are kind of glued together… how do you open them without damaging the case? I could of course go and put the drive itselff into another external drive box… would that help?