WD My Passport Wireless Pro issues

Hi there!

A few months ago i purchased the WD My Passport Wireless Pro.
I used it for one holiday and it worked fine.
Yesterday I wanted to clear all files for a next holiday so I would have full space left.

Now my pc won’t recognize the My WD passport anymore as a hard disk if I go to ‘this pc’.
However, in de device manager the MY WD pops on and off every 10 seconds.

Furthermore if I put the my WD on when not plugged in the pc, all the lights starts to flash after 20-30 seconds or so.
Connecting it through wifi is also not possible and I also tried to reset it with the 2 buttons on the device.

Also tried to update firmware via SD-card which also doesnt work.

Do you have any idea to fix this issue?

Thanks in advance!

Hello Wirelesss,

It seems that your WD My passport Drive has gone bad. I would recommend you to replace the drive with Western Digital if it is under warranty. You can refer the link given below to replace the drive with Western Digital.

https://support-en.wd.com/app/answers/detail/a_id/10336/

Thanks for your reply. Brought it back to the store and got a new one.

Hi, so I encountered the exact same problem after not having used my My Passport Wireless PRO for a few months. My PC wont pick it up, and it will randomly start flashing all the lights. My drive is just over 2 years old and I am sure no longer under warranty - surely this is some sort of firmware issue that can be resolved? This drive was expensive, I surely hope there is some way to resolve this issue

Sadly, I experienced the same issue with you all, Just bought a brand new 3TB MPWP 3 days ago, it’s still in warranty though it’s said “Out Of Region” in the warranty status.
The issue happened when I updated the firmware to the latest one (v1.04.17), once it’s finished and the UI told me to re-connect the MPWP surprisingly on the other side I found all the blue leds blinking repeatedly.
The MPWP doesn’t broadcast any access point (2.4Ghz nor 5Ghz), and the support center hasn’t reply to my ticket yet. Hoping any Guru could help me with this issue.