WD My Passport Ultra problem, wont show up

Hello, im starting a new thread on this since ive searched the net and also here on the forums for a solution on why my WD My Passport Ultra isnt showing up on my computer anymore. It worked fine just the other day but now when i connect it -nothing- happens, except for the disks light come on and it starts spinning (not any ticks or anything just the regular spinning sound). It doesnt show up in Device manager at all neither as the disk itself or as an unknown unit. And it doesnt show up in Disk manager. I was thinking about pulling it out of its case and connect it directly to my computer but then i read that the disk doesnt have a regular sata connector it got a usb/power board and im thinking that the failure might be there?

edit: I have tried it on another computer with the same result.

The disk isnt even one year we store all our pictures on it. Does anybody have any idea of what it might be and maybe if there is any solution to it?

best regards

Hello, JeppeK

Well, follow the instructions mention on the given link in order to isolate the issue.