WD My Passport Ultra 2TB doesn't show up on computer

I have WD My Passport Ultra 2 TB and today it happened. I pluged the disk in my computer but the disk doesn’t show up on the computer. In device manager also there aren’t the disk. I can hear it spinning and the light is also working. The disk was always on my desk and it was safe. I think it could happened because of my cheap USB hub.
I have many very important files and photos on it. Is it possible to somehow fix it and recover data? And what exactly happened?

i have the exact same problem with my 2TB WD … i`ve tried several methods untill i plugged it in usb 2 and i worked …seems like a cable problems . im still waiting for WD reply hopefully they will provide a solution …

I tried this but unfortunately it didn’t solve the problem. I also tried with different computer and cables :confused:


Do away with the USB Hub. Many of them can not provide enough power for the drive to be recognized by Windows.


I tried everything, also without USB hub. I think the USB hub broke down the disk :confused:. But how to fix it?

Hi. You can submit a Wd support case asking for help to fix or
replace. You may lose any files.



Have you checked your drive in disk management? Sometimes it happen when drive not showing in Windows explorer but view-able in disk management.

Yes, I checked but there isn’t the disk.

Will data recover companies be able to recover all my data if there is no physical damage?

I live in México, and i have the same problem … can WD help me??