My WD My Passport Ultra won't show up in My Computer! What do I do?

Okay so some information you may want to know:

1.It’s a 500GB WD My Passport Ultra

  1. I use Windows 10

  2. It does show up in Device Manager and Disk Management, but I can’t access any of the files on My Computer

  3. I’ve tried unplugging it, restarting, then plugging it back in

  4. I’ve tried using a different extension cord that I know works.

  5. This is my first WD Product of any kind.

  6. It use to work very well for a week or two. Then, it would on and off work, sometimes showing up as “Local Disk” though I was unable to access anything and other times not showing up. Then, after a few days of that, I have been unable to access my files for two or three days now.

  7. Whenever I plug it in, my laptop recognizes that I’ve plugged in a device with the noise, but there’s no popup saying what device was plugged in or anything asking what to do with the device. There’s only the noise.

I’ve tried a lot and I just want to be able to access my files again. If you have any ideas, please tell me. I have no idea what to do.


How is the drive showing under disk management?

Can you share some screen shots? Also, you can try using a data recovery software to see if you can get your files.

I’ve attached a screenshot of Disc Management as well as the This PC page in File Explorer. The Disc Management shows WD Unlocker, while This PC shows no drives connected other than the OS and the built-in CD/DVD player.

What data recovery software should I use?

My Passport would not show up for me either. It did not have a drive letter. To assign it one, go to Windows Start button > right click on Computer > Manage > Disk Management and make sure it’s Active and assign it a letter. This should immediately open it up for you.