WD my passport not mounting on macbook

Hi could you give me any solution. Cos my wd passport was working fine. I keeped a lot of files in it. And know I upgrade my mac operating system to OS X Yosemite and my WD was working with this system all so. but just first day. and next day then I tryed to connect it. it didnt mount on the desktop and even in disk utility. And its very strange cos then I connect it to usb the light is flashing and I hear the sound thet its working but just not mounting. please give me an answer how is possible to save my files. thanks

Same here, 4TB MyBook. Will not mount since Yosemite. I get the following error message “the disk you inserted was not readable by this compute” with three options: initialise, ignore or eject.

Is that what I your getting.

No I cant see it even in disk utility. I try to connect it with friends computer or playstation but its still not working. dont know what to do

1 Like

Hello,

We have passed this along to support.

Oh thanks for that. Didn’t know if it was a bigger issues.

Was the drive connected to the system during the upgrade to Yosemite?  Are you seeing this issue if connecting that same drive to another system not running 10.10?

Yes during the upgrade it was connected to my macbook. But as I said after the insttalation it was working, just the next day something happend. And I try to connect with other devises but it was the same problem.

I haven’t done the Yosemite update from Mavericks and it started doing this to my 2-month old 3TB MyBook today. Sometimes, if I turn everything off, then turn it back on, I get a message that “Kernel Extension is not from an identified developer” that points out the WDUSBHPDriver.kext and advises us to contact the vendor for the updated software. What are the odds that wwe can get that?

Same issue here. So assuming this is the thread to keep an eye on for any updates on when this issue will be corrected?

Mine is on My Book for Mac 2TB but same issue as with the passport.

1 Like

I am having teh same issue. My mac is not ‘seeing’(recognizing my passport.  Need advice on waht to do urgently

Does anyone know if this is going to be fixed anytime soon (or at all)?? I have so much stuff I cannot access.

1 Like

Just chiming in, my ext diskdrive has done the same thing.  Updated to 10.10 Yosemeti and it has stopped working. Ill monitor for an answer.

I am having a similar problem. I upgraded to Yosemite and then when I tried to run a backup my MacBook Pro wouldnt recognize that the My Passport was connected. I can see it in Disk Utlility and have run a repair and verification, both result in a disk running properly message. The 1 TB WD My Passport says it is mounted seems but there is a little icon underneath called disk2s10 that is not mounted and will not mount. 

The light is on and I can hear the My Passport working. 

Same problem for me

my unit (Thunderbolt Duo) was switched off for a couple of months (it worked), in the meanwhile i uprgraded to Yosemite

now it’s seen as connected in system infos → THUNDERBOLT CONNECTION > My Book Thunderbolt Duo

it says Status : Device Connected

Link status 0x1 0x2

there is a fixed white led light always on

when i boot it up, i do hear a normal HD booting inside

but, BUT

it doesn’t mount in the Finder, in DiskUtility, in the terminal

i have sent a note to the support, i have zillion of photos in it.

let’s  see

I have been in contact with support.  They think that because my drive wasconnected during my Yosemite upgrade, it corrupted something.  I find that hard to believe but it’s plausible.

I have two Western Digital My Book Studio II (RAID 0) 4GB external drives and both were on version 1015 of the firmware.  One was connected via Firewire and powered on when I upgraded to Yosemite and the other was powered off.  The drive that was powered on during the upgrade will not mount in OS X 10.10 or on another computer I have running OS X 10.9.  But the drive that was off during the upgrade will mount on 10.10 or 10.9 just fine.

I first tried upgrading the firmware using the WD Universal Firmware Updater on my OS X 10.10 computer but there is a Java conflict that I couldn’t get past.  So I used my OS X 10.9 computer to update the firmware on both drives from version 1015 to 1017 which did not help with the mounting issue but maybe that will help someone else with this problem.

The engineer from WD had me check to see if the unmountable drive would appear in Disk Utilities and it did. However, the partition under the drive was greyed out and when I tried to Verify it, it failed.  I tried this on both OS X 10.10 and 10.9 with the same fail result.  The engineer then explained that it’s likely that the Yosemite upgrade did something to the drive.

After a few other troubleshooting steps, the engineer consulted with other engineers and came back with a free software license for “Easy Recovery 11” which after hours of scanning was able to locate all of the files on the drive and restore them to another drive.  Once recovered, formatting the drive made it possible to mount again.  

Clearly something happened to the partition on the drive during the upgrade that caused it to no longer mount.  This could very well be a problem with the Apple upgrade and not Western Digital’s fault.  I will not be leaving drives connected during future upgrades, that’s for sure!  First time in 20+ years I’ve had an issue quite like this.

If your situation is like mine where the drive is viewable in Disk Utility but the partition fails on Verify, you probably need to give up on drivers or a software update fixing this and make plans to recover your data and reformat the drive.  I suggest opening a ticket and then calling them at 1(800) 275-4932 (I think it was option 4).   

Best of luck!

John

2 Likes

here i found something about a person with a Lacie THUNDERBOLT hd not being mounted anymore after os x 10.9.4

https://discussions.apple.com/thread/6434587

’  along with others I see online, indicates 10.9.4 has a bug with Thunderbolt connections. ’

Yeah, Swords, sounds like BS to me because my drive wasn’t plugged in when I updated and I still have the issue. (&Thanks for the info.)

i also have a Mabook Air

and the Thunderbolt drive was never connected to it

on that MBA i have upgraded from Mountain Lion to Yosemite

still it doesnt work there too (and iMac)

i also saw Drobo users with some issues on thunderbolt with Mavericks (not being mounted)

I have had a similar issue. I am using an iMac. I recently had a WD 3TB hard Drive replaced - TWICE in fact because the first failed after two weeks and the second didn’t work at all! This was the model with both FireWire and USB. I received a replacement Drive which is the newer 3TB USB model. Great replacement but…Unfortunately, it has compatability issues with Yosemite 10.10.1. I cannot set up the Drive Settings,  or use/find Backup or Retrieve in the WD Smartware. Smartware does not seem to recognise this Drive on Yosemite, and Yosemite does not recognise WD Smartware as a compatible version. I am awaiting a response from Western Digital who have thus far been very helpful on a personal one to one basis. Hopefully it can be resolved soon but the problem does seem to go round and round, backwards and forwards. It may be an issue with Yosemite of course, but is most likely simply that the two companies (Apple & WD) are not communicating - neither taking responsiblity for a patch or upgrade to the software. How many weeks or months will some of us have to be without backup?

no i keep getting a report that my WD is no longer supported by my apple since i upgraded to OSX Yosimate