My Passport not Recognised by Mac!


I have had the same issue with two different My Passport for Mac drives now from WD. Neither have been recognised my machine or have been recognised intermittently.

This has left me going months without a backup of my machine

I have tried using different cables and different computers to no avail

I cannot even see the drive in disk utility to reformat it

I have had 4 RMAs now with WD and the issue is still not fixed, it seems like a root fault with the firmware in the drive rather than an issue with my particular
drives being faulty

Has anyone experienced a similar issue, or can anyone help me with a solution??


If you’ve tried six drives (two originals + 4 RMAs), I’d definitely be suspecting your MAC or the USB cables – not the drives…

Apologies, not worded very well - 4 RMAs have so far yielded 2 drives (including original) that I have tried on 2 different Macs and using 2 different USB cables

Yes I had the same problem and got it to mount using his procedure I found in the Apple forum. I’m not sure if it will mount automatically but at least I can now see the contents. I’m using Yosemmite on a Mid 007 iMac.

Bill S.

“I had a similar problem with WD My Passport not mounting, which I was using as a time machine backup. Eventually found a (temporary) solution to it not mounting by opening Activity Monitor (while the drive was connected) and selecting process “fsck_hfs” and then “quit process”. The drive should then mount on the desktop and enable you to access the drive/contents. I’m not sure how the drive can be permanently repaired but in my case I reformatted it - and now it’s behaving.”