My Passport for Mac 1TB not mounting

HI all,

I have a 2-year old My Passport for Mac 1TB (USB 3.0) WDBGCH0010BSL Model, and recently it seems to have failed.

When I try to mount it, I get a brief whirring followed by a beep\click sound, and this repeats every 3 seconds for about 2:38 minutes (repeatable time measurement, which is interesting in istelf).

The drive is always visible in the USB Device Tree section of “About this Mac” --> System Report. However, it is not visible in Mac OSX Disk Utility at any point (I am using Yosemite).

Using WD Drive Utilities (Version 2.0.0.23), the drive shows up in the UI after 2:08 minutes (again this is repeatable), but nothing happens when I click either “SMART Status”, “Quick Drive Test” or “Complete Drive Test”  – there are no failures, no messages and no indication that any action has actually being executed.

This is a new Macbook Pro that I purchased 3 months ago, and I am unsure if the External Drive ever worked on it (I cannot remember exactly when I first encountered the issue), but I have tried to mount it on my older Macbook Pro (where I originally used it when I bought the drive 2 years ago), without success.

I have also tried Alsoft Disk Warrior version 5.0, but the drive does not show up there.

I have plugged the drive directly into the Power Outlet, and it makes the same whirring\clicking noise so I dont believe it is a power supply issue from my laptop(s).

As some people have suggested, I have run the Firmware Updater – while it is in the whirring\beeping mode, I get the “No Drive Found” message, but after the 2:08 minute mark, it seems to locate the drive as I get asked to Accept a License Agreement and I get informed that the “Drive is locked” and advised to unlock before continuing.

The drive was password protected, so is it possible that this is part of the issue?

The only thing I have left to try (that I can think of) is to replace the cable.

Any other suggestions would be welcome – my feeling is that the drive is hosed, but I am hoping that the fact that it displays in “About My Mac” and the Firware Updater states the “drive is locked” provides some hope for saving it.

Thanks in advance,

Paul.

PS. Some relevant screenshots below.

Hello Paulk14, welcome to the WD Community. You can try using another USB cable or compatible power adapter, if the same problem happens it would appear that the disk is faulty. You can follow the link  below for the steps to replace it. 

How to get an RMA, (Return Merchandise Authorization) or replace a defective product under warranty

Wow it like i wrote this post myself you have EXACTLY the same experience as me, the only difference is it has worked on this macbook but seems to have stopped since Yosmite update!

I can only see the My Passport in the system report hardware tree, i also when trying to update the firmware got no device detected, and then was asked to accept the license agreetment and was told the device is locked and to unlock and click continue.  Problem is I dont know how to get to a screen to unock it? 

Any updates or further advice would be greatly appreciated, i have years of work documents and 23,000 photos on this device.  I do have everything backed up to JustCloud storage so its not as much as a risk it would just be time consuming to get it all back onto a hard drive.  Also all my time machine backups are on this drive!!!

HELP PLEASE :confounded:

did it work finally? Any solutions? mine is not mounting on a yosemite