My WD passport is not working

I am using a 2TB WD passport in my mac for the past 10 months. It was working fine till now, but all of the sudden the hard disk is not getting recognised in my mac. The LED in the hard disk is glowing, but the hard disk is not getting recognized. I have tried to connect with other cables too, its not working. All my important data is in this hard disk. Please help me, ASAP.

I am having the same problem. I have been dealing with this since April and cannot figure out what to do. Have you tried the trouble shooting test thing yet? If you type in on the home page of this site “macOS cannot find my drive” it gives you a list of things to do. When I went through this test back in April I was able to do everything on it, including use the “Disk Utility” to test for problems and also run a SMART test on the drive. I don’t remember what it said at that time, but it didn’t look like it was a catastrophic failure. Tonight, I decided to try all of this again and this is what happened this time, so any help you can get, might help me also. When I checked under SYSTEM INFORMATION and clicked on USB, the external drive did show up there. But, when I brought up DISK UTILITY it just continues to sit there on “loading discs”. When I powered down and removed my passport, then turn back on and did the same thing, it immediately loaded my internal hard drive in the disk utilities section. But, that was with my passport disconnected from my Mac. So, I’m not sure if that means my problem with my passport has gotten worse. If that means that it could be completely unreadable? Or where I need to go from here. Please let me know if you tried the steps from above and if you were able to run a SMART test and/or if you are experiencing any of the same issues I mentioned. Hope we can figure this out.

Hi Indirakumar ,

Maybe you should try to check the USB port in which you are connecting the drive i.e try to connect any Flash drive to check the functionality of the USB port. Also, you can try to connect the drive in any other macOS if possible.

You can use the link below.


I have a 1 TB My Passport for Mac that I used as my Time Machine backup. Worked fine and then suddenly stopped and i had a screen message: MacOS can’t repair the disk “My Passport for Mac”.
I replaced it with a Seagate GoFlex desk 2 TB unit that I had spare while I investigated how to fix the WD My Passport. I can access the files but can’t use it as a Time Machine backup.

I think you need to erase your disk once with the Disk Utility. Backup all your data and format it using Mac OS Journaled. Chances are high it will then be used as a Time Machine backup drive. Note: Please don’t proceed without backing up its data.

Thanks. I did that after I downloaded files I wanted. Then later after I erased everything and screen indicated that the external drive was empty I had the message reappear.
I think the drive must be faulty.

This was the message i had after erasing the disk drive.before I received the next message.
Any suggestions?

try formatting the drive with terminal command line diskutil eraseDisk FILE_SYSTEM DISK_NAME DISK_IDENTIFIER

I am experiencing the same problem and like you all my important data is stored on it.

Is your WD appearing in the Disk Utility?