WD My Passport Issue

I have a WD My passport drive. It has worked perfectly for a couple years until today; the drive doesn’t show up on my computer when plugged in. The lights on the drive go on but that’s it. I tried the other USB plugs, restarting the computer, etc and NOTHING! Please help!!!



i have my WD my passport cannot unlock. i just install new windows 7 and when i connect usb my passport to my computer when i click WD unlocker it say “you must run the WD Drive unlock application from the WD Drive unlock CD associated with the drive you want unlock”  but when i put in another PC it can detect and unlock my passport WD. 

i afraid to update firmware because it can lose my data. 

Any body can help me solve this problem?

Are you using a USB 3 port?  I had same issue and the problem seems to be with using a USB 3 port.  Try using a USB 2 port and it should work.  I had exact same issue and I googled for the solution.

I had try use USB 2 and USB 3. but it can not unlock my passport WD. is this forum abandoned by WD ? no solution come from WD manufacture?

Hmmmmm.  Well I had the same issue as you and whenever I plugged my device into a USB 3 port I got your same error message.  I plugged it into a 2.0 port and no problem.  And I did this repeatedly just to be sure it was not a one time thing and I just tried before I make this reply and again using a USB 3 PORT my device would fail with the same message you are getting.

thank you for sharing this experience. i had test 5 hole usb2 dan 2 hole usb3. still same result. i just think to buy new WD passport. to save my data. after this problem. make me think twice about WD product.

If your USB 3 port is on a separate card check the manufacture’s site for the latest driver. USB 3 wasn’t the smoothest rollout.


I use motherboard Asrock 990FX Extreme4 and i just download new driver and install. and test in usb 2 and usb 3. the result is same, cannot unlock my WD passport. thanks for the suggest.