Cannot see passport plugged in usb

I have a laptop running Windows 10. My wd passport does not appear anywhere when plugged in usb port (2 or 3).
Thank you,


Have you try using the drive with a different USB cable or a different computer? Also, make sure that your computer is running the latest USB drivers.

It can also be possible that you have the ‘drive lock’ function enabled. If you confirm that it’s not enabled, I would check if your computer is detecting the drive and just not assigning it a drive letter. I’ve had windows do this before with some other external drives… Before you plug your drive into your laptop, right click the Windows logo and select “Disk Management” and let it load up. Once it’s loaded, it should display the storage devices that are currently connected. Don’t do anything with these drives, just look at how many you have and then connect your wd passport. You should see a new disk appear.

1 Like

Where could I download the latest USB drivers? I usually do the updates recommended by Windows.

I checked the disk management, when I plugged it in the usb port, it just does not appear. Where can I check the drive lock function?

The steps for the two models are the same but I linked to the manuals to both. If you have the original Passport Wireless, the details are at

The Pro model details are at

You should also see a LED light up after you plug in the drive. If you don’t I would try another cable, usb port, and computer as ERmorel suggested. If you don’t, to me that would suggest a connection issue. Whether it’s an issue with that computer or the device itself.

I’ve got the same problem with my WD Mypassport Wireless Pro running Windows 10.
When I connect the drive to my computer it only flashes its battery led’s… but if I connect
it to my Macbook or iMac it starts without any problem.

First I thougt that the USB port deliveres not enough power but other external harddrives
are working just fine.

Maybe there are some more people out there with the same problem.


Thanks, It took me some time to get to it, but I got it to function.
Thanks for your help! :smiley:

I’m using the Wireless Pro 3TB on my Windows 10 PC. When I plugged the Wireless Pro into my PC’s USB 3.0 ports (I have tried 3 of them), the hdd lights up. After a while, the battery led lights up, but my PC doesn’t see the Wireless Pro. However, when I plug it into the USB 2.0 ports, the computer detects Wirelss Pro instantly.

Anyone out there also facing this problem? How do I solve this?

Hi @kitonium - I’ve noticed this sometimes, too, with the larger capacity drives…how long do you leave the drive plugged in before removing it from your PC? Also, could you advise on your PC model (or, if home-built, your mobo or USB 3.0 card?)

I will say that it strikes me as odd that using your PC’s USB 2.0 ports registers the drive faster than the USB 3.0 ports…

Hi @AlexJ_WD,

Thanks for the reply!

Firstly, my PC is a home-built system running on ASUS mobo running on Windows 10 Pro. There are 2 sets of USB ports, the USB 2.0 and USB 3.0 ports. The Wireless Pro (3TB) always works on the USB 2.0 ports (plug it in, and the computer detects the hard disk almost instantly). However, when using on the USB 3.0 ports, the hard disk led (not the battery leds) will remain lighted, and there’s no sign of the computer detecting it. I can leave the Wireless Pro plugged into the USB 3.0 ports for more than an hour and there’s still no detection.

Upon contacting the WD support, I was advised to install the WD SES driver.I proceeded to install the driver, rebooted the PC, and the connection using USB 3.0 works. But on subsequent PC boot ups, the computer failed to detect the Wireless Pro hard disk again. I’m baffled.

I’ve used the same USB 3.0 port to connect to my other WD portable hard disk (also with USB 3.0 port on the portable hard disk), the computer detects it. …

Hey @kitonium,

From your description, this does feel more and more like an issue with the USB drivers OR, perhaps, an issue with the power being fed to the drive over the USB 3.0 port. (But again, if it works on the USB 2.0 port on your motherboard, I’d assume the USB 3.0 port would output enough juice too…)

Could you please direct message me with the specific model of your mobo (ala X370 XPOWER GAMING TITANIUM)? I’d like to pass it on to our technical team here for their review.

Hi @AlexJ_WD,

Thanks for replying! I appreciate your assistance.

I tried to find the button for a direct message, but couldn’t find it. So I guess I’ll reply here instead.

My PC is using the ASUS P8B75-V mobo.

Hope to hear from you soon.

Wai Kit

I can’t find the disk on my computer when plugged in usb port(3).I try to use WD Drive Utlities,when input a error password,it tip error.But if input a correct password,it will stop,and I had try to format the passport,it can’t work.Can you give me some help?Thanks.

I am having the same issues with no luck…

I’m also having the same issue. Brand new WD My Passport Wireless Pro 4TB, straight out the box, powered it up, connect via the app from my phone no problem, connect via the browser on my laptop, no problem, but for some reason when I connect it via USB to my Microsoft Surface Pro 4, not only does Windows 10 not mount it, it wont recognise it at all. I hear is seeking, making all of this clicking and buzzing sounds, and windows keeps dinging the sound notification to say that a device has been added, then it dings to say it was removed, then dings to say it was added, then again to say it was removed. And it does this infinitely. I assumed it might be installing drivers, but it doesn’t stop.

I tried plugging it into my phone using a USB a - c adapter and I android pops up a message saying “Corrupted WD USB drive. WD USB drive is corrupt. Tap to fix.” But I don’t think it’s corrupted because I can access the preloaded files via it’s web interface. Any suggestions?
Thank you in advance.

I just figured out that it doesn’t like running through a USB hub. This is a HUGE let down for me. :frowning: I have a portable recording studio powered 100% from the bus, my surface pro can, via USB 3, power a audio interface with a 48V phantom power mic, a guitar line, and a decent sized midi controller at the same time as my Buffalo ministation. if I unplug all devices from the hub and only plug in the Wireless Pro it wont power. Is this normal for this device?

How were you able to solve the problem?