WD My Passport is not asking for the password when connected


I haven’t used my WD My Passport wdbs4b0020 for about half a year. Today, I connected it, and it asked for a password. Unfortunately, I couldn’t remember the password and started trying different standard passwords that I usually use. After several attempts, it seemed to accept one of the passwords, as the password input window disappeared, but nothing happened, the drive didn’t connect as an accessible device. I disconnected the WD from my MacBook and reconnected it again. This time, it didn’t prompt me to enter a password. I tried connecting it to a MacBook, iMac, and Windows PC - the password input form doesn’t appear! However, I can see the drive in “Disk Utility” on the Mac and in the Disk Management on Windows. WD Discovery and WD Security are asking to set a new password, as if it’s the first time using the drive. They are not giving me an option to enter the old password! I ran a disk check in WD Drive Utilities; the first stage, “SMART status check,” was completed successfully. During the second stage, “Quick Drive Test,” an error message pops up at 10% progress stating “Quick Drive Test Error.”

How can I make it so that when I connect the drive, it prompts me again to enter the password?

Regards, Viktor

Hi @it.viktor ,

Please refer to the article: WD Security Password Protection for WD Drives Guided Assist:WD Security Password Protection for WD Drives Guided Assist

Also, Please contact the WD Technical Support team for best assistance and troubleshooting: https://support-en.wd.com/app/ask

Hi Keerti_01,

Thank you so much for your message! When I launch WD Security it asks to connect a drive; when I connect the drive, it asks to set a new password as if there wasn’t one. “Set Up Security” “Password” “Confirm Password” “Password Hint” “Set Password”.

I filled out the form at https://support-en.wd.com/app/ask