WD My Passport - Doesn't work/open in Windows


I bought WD My Passport some 4 years ago and it has been working as should, until now! No idea if it’s somehow connected to the fact I’m now on Windows 10 but I have been experiencing sudden issues with my computer not recognizing the HDD when I plugged it in. Few other times it still recognized the disk after few tries of plugging it in and out in but now when I plug the My Passport in I can’t anymore access the files! It’s so strange, because the light on the devices is blinking and I can even see it in “My devices” tab! So it indeed seems that the computer shows it as clearly plugged in and in a way recognizes it, but then I still can’t open it and browse my data stored on it as one would expect if you plug the device in. I first tried actualizing the WD Passport drivers by clicking on the option from drop down menu and trying to let my computer search for those - just to see pop-up window saying that it was unable to download any drivers so then I did it manually with the same result! How weird. So then I eventually tried installing the WD Discovery but for some reason it again ended with very similar results. When I went to “diagnostics” tab in WD Discovery it failed to do all of those tests which can be found under that tab, so that really worries me.

How it is possible that my computer recognizes the device and yet I can’t access any of my data stored on it? Why I can’t simply update the drivers if those might be old? Or is there another way how I can solve those problems?

I’m seriously lost and really worried as I would of course really need to access my data stored on the unit :frowning: and nothing seems to be working… . So if any of you might know what the problem could be or how to solve it, I would be incredibly grateful for any ideas or tips on what to do! :slight_smile:


Have you tried using the drive with a different USB cable? perhaps, a different computer?