WD My Passport 1TB USB 3.0 keeps randomly disconnecting and reconnecting itself


Just like the title says my 1TB usb3.0 passport external harddrive randomly disconnects and reconnects itself. Is there any solution to this?

1 Like

Hello Mate,

Have you try your drive with a different computer? How about a different USB cable?

Do you still encounter the same issue?

So does mine. It’s a problem with the USB cable. I tried another one, it’s better but not perfect. I tried to contact the spport from WD, but no response for the moment…

PS : (I made a mistake by answering in the other post)

ok thanks for the advice. I’ll try it out with a different USB cable.

Do you happen to know whether WD will give its customers another USB cable for free to replace the faulty one?

I don’t know, but I hope so, because I don’t want to transfert my data again (almost 1To).

Looks like it is the problem with the cable. I used a different cable and so far there has been no disconnecting and reconnecting going on. Thanks guys for the advice =) Now I just hope WD is willing to give me a replacement for the faulty cable.

My WD Passport SE had been working fine for the past year. However, I noticed that about two weeks ago it would disconnect itself while I was watching a video from it. It started out as an annoyance, but it’s gotten more frequent.

I d/led the latest driver and firmware for the WD device, as well as the latest USB 3.0 driver for my laptop  (ASUS).

That made it totally worse…the device will be “ejected” and not be recognized after about 5 minutes. However, it works just fine on USB 2.0 ports.

I’m not convinced that this is a USB 3.0 cable issue. If it were a cable issue, why does it work fine on USB 2.0?

Of course, it’s been three days since I submitted a support request to WD, and I have yet to hear anything.


I think I may know the solution to your problems. I have had no problems of disconnection after I did this. I don’t know if you have the same ASUS laptop as I do but heres what I did:

  1. Went to Control Panel

  2. Change view by to Small icons (View by is in the top right corner)

3)Go to Power Options

4)Then Click “Change plan settings” for the power plan you are using (text is in blue)

5)Then Click “Change advanced power settings” (text is in blue)

6)Then another window will pop-up. Scroll down and look for “USB settings”

7)If you click the little plus on left of USB settings, “USB selective suspend setting” will appear

8)Press the little plus next to “USB selective suspend setting” as well and “On battery:” and “Plugged in:” will appear

9)It should say DISABLED so switch it to DISABLED for both “On battery” and “Plugged in”

10)Then press Apply and then OK (Unless you want to configure other plans as well.

  1. If you want to configure other plans that you use, leave that window open and Click the down arrow next to whatever plan you are active on (it will say something like this: Power4Gear Entertainment [Active]    ^). If you click the down arrow next to that other plans will drop down. Just click whichever ones you use and set them to DISABLE.

Switching it to Disabled will solve the problem. (at least it solved it for me) 

If you have any questions feel free to post here again. Hope this helped!

A sense of relief, !! Atlast, I found a working solution to the disconnecting/reconnecting issue  after trying for a soution for almost two months now, a great gift for my birthday :slight_smile:

 Own as asus n53sv-dh51 with Win 7 64-bit  and i had been cursing WD and Asus  for  the issue. I now realise that  I should have been cursing Microsoft instead.  After changing all the power settings/ installing the latest usb 3.0 drivers/installing  a old version of  WD smartware software(as suggested somewher  as newer versions dont seem to work fine), installing the latest chipset drivers, I was still locked in a dead end.

Another attempt tonight yieled  the correct results. Guys, its an issue  with windows 7  (particxularly 64 bit version)and may be Windows 8. There  are hotfixes from Microsoft but it didnot work for me. Finally  I read in a forum to install the old USB 3.0 drivers meant for Windows XP /Vista   and  BINGO !!  My WD my pasport 1TB is behaving like it should have from the first day. Issue resolved !!! Case closed for me :slight_smile:

You are a life saver Ayssl3! This fixed the problem for me. You’ve done a fine job and I truly appreciate you helping us make use of this product. Thank you so much man.

Is it possible for you to give link to the usb 3 and smartware files. I have done everything and it still disconnects. It works for a little while after I disable the USB power part.