WD My Cluud Energy Saver

Hi all,
I have updated my WD My Cloud firmware to latest version available (V04.04.01-112),
I have configured the device via web console to “Energy Saver”=ON and I have also disabled remote connections.
But the blue front led remains always on, even if I don’t use the device for hours.

In my home network I have turned off all devices, except Internet router and WD My Cloud.
I have also noted that the led of the network interface of WD My Cluod blinks: I don’t understand why there is a network activity because WD My Cloud has been configured with remote connections DISABLED.

I’m expect that after an inactivity period disk will be spinned off, but instead the disk is always running.
Could You help me ?

Thanks in advance.

The drive will go to sleep after a predetermined amount of idle time. Unfortunately WD don’t seem to specify how long that is. However, experience seems to indicate that could be DAYS because of the time it takes for the MyCloud to scan/re-scan the media. If the status on the main Dashboard screen is not IDLE, then sleep mode will likely not engage.
The LED should do a slow BLUE blink when the MyCloud goes into sleep mode.
The network lights will ALWAYS be showing activity as long as the devices at both ends of the cable are powered on. This is normal. It is a hardware handshake that never stops.