WD My Cloud with Orange/Amber/Yellow light on for Hours

I’ve had a WD My Cloud for approximately 4 years now.I recently was given one by a sibling with a bunch of data that belonged to me, and was working fine before it was unplugged.

When I plugged it in to hook up to my network, it’s hung up on a yellow/orange/amber LED. The device no longer shows up, and while connected to ethernet, only one light blinks intermittently. I’ve left it this way for hours with no change. I’ve also attempted a 40-second reset, and know it has worked as my phone no longer can find the drive anymore.

Despite that, I’ve rebooted this drive in the past, and it’s never taken more than 15 minutes at most. I still want my data off of it. But it’s still in “initializing” mode, and not talking to the network.

Network is the same, using a Ubiquiti Unifi network. I have another WD My Cloud that has no issues, so it is not network conflict.

Drive is the 00 variant, 4 TB.

Already tried different ethernet points, different ethernet cables. Plugging it directly into a PC changes nothing. All computers are Windows 10 OS.

Any ideas short of breaking the drive apart?

Have you tried a different ethernet cable? Can you access the dashboard? Is it getting an IP address from the router?

The single bay My Cloud user manual (for the first gen v4.x firmware) has a section detailing what the various colors of the front LED indicate. See page 12 (http://products.wdc.com/library/UM/ENG/4779-705103.pdf#page=12) of the PDF. Generally a red solid front LED indicates:
• Disk thermal warning threshold
exceeded (under or over temp)
• Ethernet cable not connected
• Disk SMART failure
• Data volume does not exist
• System volume does not exist
• System thermal shutdown (75 C)

A front Yellow LED typically indicates a network issue per Appendix C (page 95 - http://products.wdc.com/library/UM/ENG/4779-705103.pdf#page=95) of the user manual.

The My Cloud Device’s front panel light is yellow and the unit’s Network
Adapter LEDs do not light.

  1. Confirm the network cable is properly connected to the My Cloud device and the
    network switch or router.
  2. Make sure the network switch or router has power.
  3. Use a different network cable and port on the network switch or router. Temporarily
    swapping the My Cloud device’s cable port with a working network device may identify
    any failing cables and ports.

If you have tried the basic troubleshooting steps; 40 second reset, different networking port on the router, putting a network switch between the My Cloud and router, use different ethernet cable, connecting the My Cloud directly to a computer using Ethernet. Then its possible the hard drive within the My Cloud has an issue that is preventing the proper loading of the unit firmware/OS. One can extract the hard drive from the My Cloud and connect it to a computer running Linux or a Linux driver to read the contents of the data partition (usually partition #4, which is in EXT4 format). From there one can recovery their data and copy it to another location. If connecting the My Cloud hard drive, using a USB to SATA (or docking station or spare SATA port) to a Windows computer one will need to use a third party Linux driver to read the contents of the data partition. Or use a Linux Boot Disc/Boot USB Flash Drive.

There are a number of methods to “unbrick” or recover a My Cloud hard drive back to working order. Most methods however do involve some knowledge of how to use Linux and Linux commands. If the hard drive has gone bad (not surprising given the age of the first gen single bay My Cloud units) one can replace the hard drive with a new (or newer) one using one of the various unbrick methods.

User Fox_exe has a set of unbricking directions for a first gen that works fairly well to replace the My Cloud hard drive. One could experiment with those directions and try to fix their existing My Cloud drive by skipping the sections on reformatting/partitioning the hard drive and go to the steps that detail how to push the IMG files to their corresponding partitions as indicated in the directions. As always proceed at your own risk!!!

User Fox_exe repositories:
Main Repository: https://fox-exe.ru/WDMyCloud/
First Gen: Fox_exe file archive

First gen directions:
English: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Replace%20HDD%20-%20English.txt
Russian: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Replace%20HDD.txt
File(s) used in first gen:
original_v03.04.01-230.tar.gz: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Backups/original_v03.04.01-230.tar.gz
original_v04.01.02-417.tar.gz: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Backups/original_v04.01.02-417.tar.gz
Latest first gen firmware: http://support.wdc.com/downloads.aspx?g=904

@Bennor I have the same issue. I have almost 2TB of files I need to recover from my WD My Cloud drive.

I took the case apart and noticed on the circuit board a capacitor was ruptured. The hard drive has a solid amber light that’s stays on and it will not connect to the internet.

I can hear the disk spin too.

I purchased an external SATA case to pull the data off the disk. Is the only resort I have is using a Linux computer to download my files off the hard drive? I really need these files any help, recommendations or advice is greatly appreciated!

Thank you in advance!

See the link previously posted about using third party Linux drivers on Windows to read Linux formatted drives and partitions.