WD My Cloud Set-Up problem

I bought WD My Cloud few years ago, i’ve been using for 2 years. And then i just left and unplugged it. Recently I got myself new router and decided to plug the Cloud back in. However My Cloud doesn;t want to connect. White/yellow LED flashes which as i read in a manual means “no connection to router”. I connected it but only one green LED ligts on the LAN port. Also my router doesn’t recognize My Cloud or just doesnt sent packets, i don’t know. When i plug this LED on router just doesn’t show up. Anyone have a good solution so that I can again be happy using My Cloud?

@Hubson After plugging the My Cloud into the router did you reboot the router? Have you checked the router to see what address, if any, was assigned to the My Cloud? What brand of router do you have?

@cat0w If by rebooting you mean clicking the restart button for 40 sec then yes i did. I have Nokia router, I’m not so fluent in those things so can you tell me how to check the adresses?

@Hubson The question ask, did you reboot the router, not the My Cloud! Rebooting the router should reconnect everything you have connected to it.

I use Linksys router, but have you looked at the User Manual for your Nokia to see how to check what DHCP addresses were assigned and see if you can reserve them? See example image below.


@cat0w sorry misread that. I rebooted the router, but it didn’t help. Unfournately my router doesn’t see the My Cloud, even though it’s connected. There is no My Cloud mac adress on connected to router devices

Have you tried a different cable to connect the My Cloud to the Router?

Actually I tried all Ethernet cables I have and all of them al fully functioning. Is this possible that the LAN port in MC is broken? Both led are flashing green so it shouldn’t be broken

@Hubson Have you looked at the User Manual, LEDs? Yes, it should be working.

Yes, I’ve read this. I unplugged from the power and now only one LED flashes. I guess the one which means “active communication” doesn’t flash

I think it’s a power supply error. I plugged it via different one and it stared booting, now i just have to find different power supply. I hope it is it. Thank you for your help