LED never turns blue - first install

I just purchased the 3TB My Cloud.  Hooking it to new Cisco Wireless Router.  The LED never turns blue, it is always light puple looking which I’m assuming is supposed to be white.  The network connection is blinking green and yellow at the router but at the My Clound it is only blinking Green.  The Cisco Linksys Smart Wi-Fi interface shows an unknown network device which is “offline” so it might see it but not be able to communicate with it???

I’ve tried:

  1. Resetting everything and turning it back on in the order Wireless Router, My Cloud, Windows 8 Laptop.

  2. Plugging the device directly into a wall outlet and not a surge protector.

  3. Pressing the reset button

  4. Unplugging the unit - pressing the reset buttion while plugging it back in and holding for 45 seconds.

  5. Plugging into a differnt router port that I know is working.

Support is closed for the holiday, any ideas?

Look through all the posts.  Mine was not being detected, then suddenly it was detected with no changes/actions on my part, then it is not unable to connect.  These problems are being experienced by so many people.  WD must be selling defective goods.

How long did you let it run? White LED means it may be booting up still and running a FSCK.


I’ve let it go as long as 30 minutes while watching it.  I let it go overnight also so for the the last 12 hours it has been connected… still white.

If you did a reset during boot (white led) it is most likely bricked for now.

Thanks BullZeye and everyone who responded. 

I talked to support tonight as well.  In addition to the things I’ve already tried they had me try to:

  1. Shuf off my firewall - did not work

  2. Shut off my live monitor antivirus (Defender) - did not work

  3. Plug the My Cloud directly into the laptop ethernet port - did not work.

They recommeded that I return it for a new one which I will be doing tomorrow.