WD MY CLOUD & Samsung Smart TV

I’m looking for a way to remove my WD Cloud from showing up on both my Smart TV and my Andriod box. Even tho my files seem secure on my phone or laptop and therefor inaccessible to the childrens and neighbours phones, laptops etc my TV and Android box shows my 4tb WD Cloud as a source and ‘’‘everything’’’ is visible! The TV and Andriod box are only connected via LAN as is the MyCloud. I can’t work out how this has happened and how to undo it. Any help would be appreciated.
Thank you
Ell

I’m sorry to waste anyones time… I’ve sorted it. It was the Media Serving setting in the Shares Folder setting. I turned Media serving OFF. Thank you anyway

Have you read your TV’s and Android box User Manuals? On your TV have you clicked the Home button and looked at the Menu?

My new 4K TV is a Sony and it is easy to add or remove apps or other items. My home network has a User Name and Password as well as Netflix, Crackel, Vudu and my Roku.