WD My Cloud remote access is not fixed

I am still having problems since the failure and supposed repair of the WD My Cloud servers remote access getting any of my remote users reconnected to my 4TB MyCloud device. I have resent them invitations, had them use the forgot password reset routine and no go. My Dashboard tells me that the device is connected but no one outside my network can log on to the device with My Cloud software. This just started with the failure the other day. I have tried three calls to the support line (in India obviously) and I’m getting nowhere. Someone please help with this I don’t have any more time to waste on it!


Do you mean My Cloud Desktop App, Mobile App or MyCloud.com via web browser?
Is you unit in Port Forward or replay mode? If Power Forward, you may want to reboot the router and the My Cloud unit.

did you try 4 sec reset?

Both the My Cloud Desktop App and the MyCloud.com web browser fail to connect. I have not tried a 4 sec reset (Will that wipe out the files on the drive?) but I have rebooted the drive multiple times.

I have also added port forwarding for port 80 and port 443 on my Surfboard 6580 cable modem which I have never had to have on before but that was no help. The tech support used the yougetsignal.com website to say " yep there’s your problem those ports aren’t open" which was bogus as my MybookLive devices are both working without that now just the WDMyCloud device refuses remote access.


My Book Live and My Cloud use the same ecosystem (mycloud.com / wd2go.com)
Did you submit My Cloud logs to support? PM me your case number please.

4 sec reset not wiping files so dont worry

also read this please to:

and then read this:

I don’t see a button for sending a private message.

Hi @bnwitt - to send @SBrown a private message, click on his name and than click on the “Message” button.

Very often I can not reach my mycloud, still offline after login on mycloud.com :confused:

Ok everyone thank you for your help on this. The 4 second reset did not work, but the 40 second reset worked on the second try. I wish I understood exactly what setting is being undone with the reset and whether or not it could be adjusted from the Dashboard. Oh Well, now I know what it takes to get things talking again. Thanks to all.

Well, I guess I spoke too soon. Remote access failed right after the 40 second reset. I’ve done the reset several more times and it works for one logon then everyone gets the error messages again. I am really frustrated and I have spent hundreds of dollars of my time messing with this problem. I think it is time to abandon cloud access with my three WD devices and just pay for a real cloud service. These units are a real PITA.

Well the forum moderator was kind enough to elevate my problem to WD support. I received two replies from support very quickly afterward on a Sunday no less (but I think it may be Monday in India). Unfortunately they both recommended I update the firmware and reboot the drive. The firmware is already the latest version and I’ve rebooted till my eyes turned red. This problem started when WD’s servers went down this week. It is clearly something on their end and not something that requires me to reboot my drive over and over. I remember when I first bought a WD NAS and everyone was having problems with remote access. It took them forever to get it fixed. I just don’t have forever again. My time is too valuable. I will just use the three units I have for network storage and am now paying for an online cloud storage that I can count on. I will never buy another WD product again because they out source their Technical support to India where operators are standing by to read you the same canned solutions from the support manual which will not help you because the problem is not with your unit but the cloud system itself. If you want to waste a huge amount of time getting nothing done then WD is the company for you.

1 Like