WD MyCloud No Longer Accessible


I have been happily using my WD My Cloud for about two weeks now, on a network of about 7 computers, both desktop and laptops, several wireless devices, and a few remote access devices, including phones, laptops, etc. 

Two days ago I tried to access a folder on my My Cloud remotely and it was giving me the following error:

“Unable to access device. (0)”

That night, when I arrived home from work, I checked the drive, blue light on, spinning, it seemed just fine. But I was unable to access the files remotely or on the network. When I tried to access the folders on the network it just sat there for a few minutes, blank, trying to find something then it would say: “Windows cannot access \WDMyCloud\FolderName” with a diagnose button, which, go figure, didn’t help with diagnosing the problem. 

I tried unplugging the device, waiting about 30 seconds then plugging it back in. IT WORKED JUST FINE! Everything was working again.

But now, two days later, I am having the same problem, and cycling the power is not working. What else can I do?

(I forgot to mention that both times the problem occured I was unable to access the drive through the IP address, it would sit and load forever, then eventually add “/UI/” but never get anywhere.)

Thank You in advance!

Hello Ubiquitouz,

Have you tried resetting the device using the hard reset button on the device?

Check on page 119 of the user manual for more information.


I’m not sure resetting the device is the correct answer.

When you are 5000 miles away how do you do this? The device continually fails to remotely connect on any device (intermittently but daily).

I have a support request open for 5 days now with no reply.


It would be helpful to know why this is happening rather than just “reset” as this is not a practical solution as you can’t just keep doing that! The whole idea customer have invested time and money in these devices is for the convenience and reliability of setting them up once and accessing them numerous times across numerous devices with out constant tinkering and resetting. These devices should be designed to run in the background unnoticed. So. Wd can we have some fixes that makes these devices “fit for purpose” as defined in sales of goods act.

Very similar issue with me. MyCloud worked great right upto the software update in Jan. After that, no access at all. Rebooted the drive, switched off sleep mode and finally got access back on my network and on wifi BUT no access remotely through Android WD app or website. Tried several options on this forum and no luck. I’ve just opened a ticket with WD support.  I also don’t think resetting the device is the answer. Defeats the purpose of having a cloud.

Anyone else experience this specific issue?

I also have this issue after installing the firmware update (v03.03.01-156).  I created another thread with this issue before I saw this thread…it looks like lots of people are having this same issue.

See http://community.wd.com/t5/WD-My-Cloud-Mobile-Apps/After-firmware-update-v03-03-01-156-Unable-to-access-device-0/td-p/666077

I have the same problem and tried reset, updated firmware, reinstalled app. None of them work. This WD My Cloud has fundamental problem- it is defect product. How could WD expect users to rest harddrive all the times ? We need permanent solution instead of “reset”.

Same Here.  My EX-4 becomes inaccessible remotely about once a week and requires a restart.  When it is happening, I can still access it at home over my wifi.  Everything is normal locally through the dash board.  This is something that the sofware developers need to look at!!

I’ve opened two tickets so far with WD support and I’m getting no where.  These guys want to give you the FAQ standard answers.  


Well, my strongly worded post did get a response from technical support and I was contacted that evening by a tier 2 engineer.  He seemed very knowledgable and even performed a remote connection session to check my EX4 settings, etc.  

He could not find any issues with my settings but found that my ISP was blocking certain ports, like 8080 and suggested I contact them to open.  

Heres the thing - my system works great for days.  After several days it becomes inaccessible.  The port issue is a constant - if this were the cause it would not work - PERIOD.  Well, as usual, the tech stuck on that issue and suggested that I contact my ISP, eveb though he had no reason to believe that this was the cause of my problem.  I told him I would contact the ISP and asked that he keep the ticket open, which he agreed.

I contacted my ISP and was told that they do block 8080 and cannot open it.  So I went back to update the ticket and it is closed.  Guess I’m opening another ticket…This is so annoying.


Might I suggest a different approach?

Ask your ISP for a listing of all blocked ports.

Use that info to select two open ports with MANUAL port forwarding of the My Cloud EX4.

That removes the ISP blocking question from the discussion altogether.

I’m having the same problem as well and I’ve included a screenshot.

I’m using the MyCloud app to access my WD EX4 and I get this message frequently.  I thought maybe in standby mode this might happen, so after waiting like 30 seconds or so for the drives to spin and come out of standby mode I tried again with same result. I wish there was more specific user defined control options for setting the amount of time before the EX4 goes into standby mode but despite the greater control, the unit should begin going online and out of standby mode the moment you attempt to access your files remotely.  In a remote location we have no ability to reset the device, that’s the purpose of having remote cloud access in the first place. As suggested previously to reset the device, that is not an actual fix to the device as this doesn’t happen every time and works fine on occasion without requiring a reset. Therefore reset is not an adequate solution to suggest. It’s obvious this is a widespread issue based on the many threads and posts related to this issue.  Please WD, help us figure out what is causing this so we can access our cloud at our leisure and not when our cloud decides to finally grant us access. 

1 Like

As an update to my previous post, a WD tech had me relocate my EX4 to another part of my network, directly attached to the router, as opposed a remote switch.  It took about 12 days for this to reoccur after that, but it is still happening.

When it fails, it is still accessable from my local net and wifi, just not remotely over the internet.  It will stay this way until a reboot.

I’ve emailed the WD tech, but have not heard back yet.  I’d like to leave it in the failed state, hoping they can figure this out.

I’m still having the Device Not Accessible problem and Tech Support says it’s a server maintenance issue on their end.  I’m getting really frustrated when I buy an expensive product like this and they have video advertisements on their website that show people camping, sitting in the park and riding trains, all while browsing and streaming data from their own cloud yet I can’t myself.  This problem has been on and off since I purchased this unit in December and now I can’t connect at all this entire week.  I purchased this product to use at my own convenience, not when WD servers just happen to be running properly.  Tech support said they will give me a call to inform me when their servers are running again but I want to know why they have people making courtesy calls instead of spending the same time to just fix the initial problem.  Are we to just sit around and wait another week and hope the service is restored? I didn’t spend thousands of dollars on hardware, drives and fiber connection equipment to not be able to use it at my leisure.  As a big WD fan I’m very disappointed and frustrated right now. 

I am experiencing the same problem on MyCloud 2 TB, every one is discussing. While I tried to access the website https://wd2go.com it didn’t opened, tried on several computers and devices.

While their wd2go.com is down, I think. Thats why whenever I tried to create the user, it  displayed

"This email account cannot be deleted. Make sure your device is registered and your network connection is functioning properly, and then try again. (250010).

When I tried to get the code for cloud devices the error "

  • Failed to generate code for your mobile device. Please make sure you do not have any network connectivity issues and try again. (250004) " appeared.

I couldn’t connect from my smart phone after I done factory restore “System only”. Their website https://www.wd2go.com was down. still not working

Hoping it will become alive again soon. any knows the solution kindly advice, My network and Internet is working fine.


meant as PM

Has the My Cloud system crashed? my device is working but cannot connect to the My Cloud servers and wd2go has disappeared? Is there a services status page on there website that shows us any network issues etc like hosting companys have? Ian

Restar your PC and login again, you will gain access locally only.

WD Mycloud server wd2go.com is unreacheable, thats why you couldn’t access it remotely.

You’re not alone. It’s not working for me either.  I can’t even access wd2go.com

Hi im don’t have accesoriess to wd2go.com - web is not running.

This time is not add user, and synchronization from external user /mobile phone 3G/ …

im wait, if web running.


Been doing my head in trying to register another remote access user since Friday afternoon on my MBL 3TB.  Pure coincidence, I’m sure, remote access has been working flawlessly for me all last week, but then, indications lead me to believe it was UPnP or port forwarding problems at my home network, or even port blockingat my ISP , but when I couldn’t access wd2go.com etc, started suspecting something was more fundamentally wrong.  I’d have hoped there would be a formal announcement by now though - does anyone know if there is a twitter feed, or message board where WD make these sorts of service announcements?