WD My Cloud Personal Cloud Storage 4TB Running MyCloudOS5 suddenly red light blinking

Hi all, so I was working on my wd as usual and decided to open the dashboard to check if there is a new firmware update “I like to stay up to date with the updates”, I opened the dashboard put my password in and the dashboard froze, tried to access the the drive from the mounted network, no luck, unplugged the power cord then put it back in and it’s red blinking light, tried everything, 4sec, 40 sec, unplug, replug, changed the the ethernet cord, changed the port, switched from a switch to the router, nothing, then I found some articles about taking the drive out and putting it inside the PC and using a software to view the ext4 file format and access it, so here is what i did:

  • I have a windows 11 desktop
  • I plugged the drive into the desktop with SATA cable and SATA power
  • Windows detected the drive and wanted to format it, I refused
  • I opened Linux File Systems for Windows by Paragon Software, but it didn’t detect the drive, tried other software, no luck, am I doing something wrong?!

I really need help with this, this drive has over 32 thousand family photo and video, I can’t lose these files

note: the drive used OS3 but I updated it about a year ago I don’t really remember when.

SORRY FOR MY ENGLISH, I’m no native.

What specific My Cloud device do you have? A single bay/single drive second generation My Cloud or one of the multi bay My Cloud models?

You may want to move your post to the appropriate OS5 subforum for your OS5 My Cloud device since the OS3 subforum is for end of service/end of life OS3 devices that cannot be updated to OS5.

As a troubleshooting step, try using a Linux boot disk or boot USB flash drive and see if that Linux OS can mount and see the drive (EXT4 partition) contents. Ubuntu is one such popular Linux distro that can be burned to a DVD or flash drive for booting.


Are you saying you don’t have any backups of your photos and videos?

Backup Definition (techterms.com)

Okay Will do as you said and move the post to OS5, and I have single bay/one drive, the white one, don’t know if it’s second gen or whatever.

the biggest mistake of my life, no I have no backup, I thought this drive will last a good 5 years or so.

here’s the os5 one