WD my cloud home permissions greyed out

So I have a WD my cloud home 4TB with a WD my book 4TB plugged in via usb3.
Last week everything worked great, however, for no apparent reason I cannot write anything to the my book HDD.
I have gone to the dashboard, there is only one user, Admin, and all permissions are greyed out.
Go to shares, click on the my book & public is turned on & all permissions are on public but greyed out.
Turn off the public radio button, (media serving is on, but even if turned off same problem) it says updating, click the read/write for user access and it says I now have read/write access.
Try to copy or drag a file to it and it goes back to no access.
Tried rebooting the cloud drive, ejected the my book and plugged back in. Still goes back to “Deny Access” and the public radio button has turned itself back on…

@normski4ash What WD device do you own? A My Cloud Home does not have a dashboard.

Use this link to see the different WD devices. http://learn.mycloud.com/

Oooooppsss Sorry it’s just a my cloud…