Wd My Cloud doesn't show up on network no matter what

I have tried everything.
Connecting the Wd my cloud directly to a computer - doesn’t work
The reset button - doesn’t work

The Wd my cloud worked for a month but since I can’t find it on the network no matter what.
What to do??


What color is the front LED? Blue, White, Red, etc.? Are the back LED (network port) lit up when you connect the My Cloud to your computer or to the local network router?

Have you tried a 40 second reset?

The front light is steady White. The back port is Green for 10 sec then it’s flashing green every 5 sec.
None of the renset functions works

What firmware version or what generation (gen 1 or gen 2) is your My Cloud? One can check the My Cloud User Manual (http://support.wdc.com/product.aspx?ID=904) for more information on what each LED color means.

For the older v4.x first gen My Cloud’s, a blinking white front LED indicates the following:
• Displays when you first apply power to the unit.
• Reset pressed.

A solid white front LED for older v4.x first gen My Cloud indicates the following:
• Device has begun loading the Operating System (OS).
• Firmware update in progress.

Sometimes one may have to leave the My Cloud unit alone for a lengthy period of time after powering on to let it finish scanning the internal hard drive. If after letting the drive sit, the front LED remains white it may be a good idea to contact WD Support (https://support.wdc.com/contact.aspx) to initiate a case and possibly RMA the drive under warranty if it is still under warranty.

It’s a older v4.x first gen, so it indicates that a firmware update in progress. So your advise would be to keep it on for a day or something and then see?

Also check the device IP via your router’s UI. Try accessing via the IP address; if you haven’t fixed it at the router, the DHCP server in the router may have changed it.

Nothing happens… solid White in front. Flashing green from the netport. I DONT KNOW WHAT TO DO

Well, you could do as suggested above, and contact WD Support. We’re not WD Support; we’re customers like you.

Or, if you’re familiar with hardware and Linux, and aren’t worried about violating your warranty, you could open the device up and recover the data (if you haven’t got the data backed up on a backup disk) using either a Linux PC, or a Windows PC and the Paragon Extfs file system extension, and then try to follow one of the many ‘unbricking’ guides on this forum to restore the MyCloud OS; it sounds like it has corrupted its OS during a firmware upgrade.