WD My Book not working

Hello People, 

I’ve tried to google this issue but I can’t find any answers. 

I have a 2TB WD MY Book powered 3.5 HD, with a Toshiba Satellite A500 laptop. 

The HD works perfectly fine through a powered USB hub to my laptop but when connected directly to my laptop will not work. It wont even display the white light on the front. If I wiggle the USB I may get a quick flash but besides that no recognition at all. I’ve tried this in all 3 USB ports by the way. 

Well why don’t you just use it in the hub you say? Good question and I do but this means as it’s a powered hub even when the computer is off the HD is still on. 

Turn it off you may say, this is a pain as the powerboard is behind my desk and I will have to pull it out all the time… 

I digress… If anyone has solved this issue before can you please let me know. 



Have you tried replacing the USB cable. It is possible the USB cable is defective and it is only making a good connection when you use the USB Hub.