WD My book live - cannot acces via wd2go

Since few days I cannot enter my wd my book via wd2go.com. I tried on windows xp, windows 8. I am able to log in, select the device, it says that the web’s certificate is unsafe. And when I accept unsafe certificate, it gives me Java Runtime error “Classnotfoundexception”. I have the newest Java version, no antivirus, I have tried switching off firewall on my computers. Nothing helped. I am sure that with other applications Java is working fine.
Strange thing is when I log on wd2go.com at home, where wd is connected to my router, but I still log via web site, not via local network, I can acces it, without Java errors.
Thank you in advance.


Have you tried with different internet browsers? Do they provide the same results? If so, what happens if you disable remote access within the Dashboard of your unit, perform a physical reboot, and try to reconnect once more?

Yes I have tried Chrome, Mozilla, IE. Like I mentioned at home I can acces it witout any problem. Could that be the router wrong configuration? Few days ago I have changed my router, could that be the issue?

I am having the same problem trying to access via Safari. Java 64bit is not supported on Chrome so will not work via Chrome. Mine works via local WiFi acces but not via the internet WD2go.com access. Same certificate error.