WD my book essential

hello guys !

i have a little problem here, actually it’s a big problem and i appreciate if you can help me

i used my WD mybook essential yesterday and it worked without any problems, today when i plugged it in, it didn’t show up on ‘this PC’, i just can’t find that icon of my book, it’s not like it’s not connected or something, i mean everything worked perfectly, i hear the sound coming out of it like spinning disk, there is sound coming out of my laptop when i plug it in indicates new device, so i don’t know where is the problem exactly or what should i do, i really afraid of losing that amount of data, it’s really important and i can’t replace it anyway anyhow

can somebody help, i’ve read a lot like this problem before but no solution, is this it, just throw it in the garbage :confused:

still can’t fix it no matter what i do :confused:

any thoughts??

Hi ahmedragab ,

Probably, you can check if the drive is showing in Disk management(Windows OS) or Disk Utility(macOS).

We will be waiting for your update.