WD My Book 4TB does not Mount - New out of box

I have been attempting to deploy a WD MyBook 4T on a Mac Pro 5,1 running Mojave - Mac OS 10.14.6. The drive does not mount, or IS visible in Disk Utility. Tired installing on a machine running Sierra, and a Win 10 Laptop - same result. Oddly the USB buses can “see” an attached device, but no volume. Tried most of the solutions in the support Knowledge Base. Installed WD Discovery and the software seems to “see” the drive, but it still does not mount. Knowledge base suggests drive might be locked - but I have no idea what any “old” password might be to edit or ulock - this drive is NEW OUT OF THE BOX.

Who ships a locked device???

Help? Otherwise the poor thing is a shiny paperweight.

Attempting to reformat the drive to a Mac-friendly format using Drive Erase in WD Drive Utilities (does not appear in Disk Utilities) But the process seems to have stalled at about the 60% progress mark. SQUINT

Reformatting failed. Let it sit overnight - no progress. Had to Cmd-Option-Esc out of WD Drive Utilities. WD Discovery still “sees” the device, as does System Report > USB. But still no mounted volume. Still does not appear in Disk Utility, or any other Disk Utility/Data Recovery application.