New My Book 4TB Not Showing on Mac

I’m having a hard time with a brand new 4TB My Book not loading up on my Mac. I’ve never had any issues with WD external hard drives on this computer before. This new hard drive will not mount properly. Here’s what is going on and some things that I have tried over the last several days:

  1. When it wouldn’t mount on my Mac or on my Microsoft Surface Pro I took it back and exchanged it for a new one. The new one is having the exact same issues.

  2. On my Mac, when I go into System Information and look at my USB Device Tree I can see that it does recognize that the drive is hooked up.

  3. When I go into Disk Utility it does not show in there.

  4. I have tried resetting the PRAM/NVRAM to no avail.

  5. I have tried to download and install the WD Turbo drivers direct from WD’s website to no avail.

  6. I have tried all manner of disconnecting cables/power cords, shutting down, reconnecting.

About my Mac:

OS X El Capitan (10.11.6)
All 3 of my USB ports on the Mac itself are 2.0.

As I mentioned above, in an effort to see if there was a fault with the drive itself I did try to see if it would work on my Surface Pro running Windows 10 with a single USB 3.0 port. Windows does acknowledge that the drive is connected, however, it does not show in This PC. If I go to Devices, it does show there. I have tried to initialize the drive using both GPT & MBR and neither will work. In fact, in Disk Management, the drive doesn’t show that it actually has any space. It’s blank. When I try to initialize using GPT it says the drive doesn’t meet the size requirements. When I try to use MBR it gives a fatal device error. The first external drive I bought did the same exact thing before I returned it. I kinda find it hard to believe that I’ve gotten two straight duds.

I tried to uninstall the drivers on the Surface and then even uninstalled the USB device drivers, rebooted, and then plugged the My Book back in to reinstall the drivers. Still couldn’t get it to work.

I want the external drive to run on my Mac preferably. Nothing I have tried has worked at all. I can’t seem to get this figured out. Any help would be awesome.

Hi vaderSW1,

It seems like the drive has gone bad, as it is showing the fatal device error. We would recommend you to replace the drive if it is under warrant period.

Please refer to the link given below in order to know how to get how to Get an RMA to Replace a Defective WD Product.