WD External Hard Drive Problems Need Help! (Descripted)

Hello, and thanks for viewing this post!

Well, a brother of mine recently came over, and asked me about this WD External Hard Drive? Quite new to them, It’s like a black box and the front has a Line in the Center that lights up blue ‘Stays Lit While plugged in’

Okay, it does not make any noise while it’s On

So i did a Bit of Research on this

i’ll try and give all the details to give you a better picture of my problem

First i went to Computer -> Device Manager -> and i see it as it’s plugged in and it’s only called ‘WD’

So what i did was clicked it.

The Box that opens with tabs everything, basicly says

WD Properties

General Tab

------------------

Device type: Disk Drive

Manufacturer: (Standard disk drives)

Location: on USB Mass Storage Device

Device Status

This device is working properly.

 

 

Policies Tab

-----------------

Removal policy

Quck removal (Default)  <- automatically Selected

Disables write caching on the device and in Windows, but you can

disconnect the device safely without using the Safely Remove Hardware notification icon.

Better performance

Enables write caching in Windows, but you must use the Safely Remove Hardware notification

icon to disconnect the device safely.

Volumes Tab

------------------

The volumes contained on this disk are listed below.

 

Disk:    -

Type    -

Status -

Partition style -

Capacity -

Unallocated space -

Reserved space -

 

Also, there is 2 buttons to choose from

 

Populate and Properties. (Populate is the only button you’re able to choose.)

Once chosen Populate it’ll read.

 

Disk: Disk 1

Type: Unknown

Status: Not Initialized

Partition stle: Not Applicable

Capacity: 0 MB

Unallocated space 0 MB

Reserved space 0 MB

 

The (Properties) Button is still un accessible.

 

 

Drivers Tab

-----------------

 

Driver Provider: Microsoft

Driver Date: 6/21/2006

Driver Version: 6.1.7600.16385

Digital Signer: Microsoft Windows

 

Below that are a list of Buttons.

 

(Driver Details) -> to view details about the driver files.

Once clicked, it shows 2 listed Driver Files.

 

C:\Windows\system32\DRIVERS\disk.sys

C:\Windows\System32\drivers\partmgr.sys

 

(Update Driver) -> to update the driver software for this device.

Once clicked, it’ll say The best driver software for your device is already installed.

 

(Roll Back Driver) Not able to click.

 

(Disable)

 

(Uninstall) -> To uninstall the driver (Advanced)

 

I’ve clicked that button, and it uninstalled had to restart my Cpu.

once it started back up i re plugged in the usb, and it loaded like making that little noise that it Read

and was able to connect, but still same problem. (Read it online that it sometimes fixes it)

Details

-------------

 

Has a drop down box menu to choose from, if needed please let me know which one to Explain.

( mas many :-p)

 

 

Okay, So after attempting to try and reformat it ect or looking for ways, from that area.

was reading more about other ways to fix it.

 

So my next attempt was

 

Computer -> Manage -> Disk Management

 

Okay, upon opening the ‘Disk Management’ i get message box Saying.

 

Initialize Disk

 

You must initialize a disk before Logical Disk Manager can access it.

Select Disks:

 

[] Disk 1 ( Already Checked)

 

Use the following partition style for the selected disks:

 

[] MBR (Master Boot Record)

[] GPT (GUID Partition Table)

 

Note: The GPT partition style is not recognized by all previous versions of Windows.

It is recommended for disks larger than 2TB, or disks used on Ilanium-based computers.

 

(Attempting to click both of the options given Above a Pop-Up comes up and says.)

 

Virtual Disk Manager

 

Incorrect Function. (only option is to click OK)

 

After that it dissapears (the little Pop-up)

and what caught my attention was it’s called

 

Disk 1 (Shows a little Red Arrow going downward on the Picture)

Unknown

Not Initialized

 

Upon right clicking it, it gives me these options.

 

Initialize Disk -> Which is unavalible and i’m not able to click it.

Offline -> When clicked it’ll give me that error message again.

Properties -> Everything i typed about it above.

Help -> Which don’t really help me with the problem >.<

 

Okay, so after that i decided to check a bit more research online

and was lead to another option.

 

Called 'Western Digital Data LifeGuard Diagnostics - DLGDIAG for Windows’

 

Okay, in this area i’m  able to see the 'WD (USB)'

as it reads from left to Right

 

Drive #      Model Number           Serial Number           Capacity           SMART Status

2                   WD (USB)                                                            0MB               ? Not Available

 

 

Alrighty, so once i double click the 'WD (USB)'

 

Opens a pop up window with 4 options.

 

Quick Test/Extended Test/Write Zeros/View Test Result

 

Here are the Test Results.

 

Test Option: QUICK TEST
Model Number: WD
Unit Serial Number:  
Firmware Number: 1.75
Capacity: 0.00 GB
SMART Status: Not Available
Test Result: PASS
Test Time:

16:13:47, November 04, 2012

 

Test Option: EXTENDED TEST
Model Number: WD
Unit Serial Number:  
Firmware Number: 1.75
Capacity: 0.00 GB
SMART Status: Not Available
Test Result: FAIL
Test Error Code: 08-
Test Time: 16:14:01, November 04, 2012
Test Option: WRITE ZEROS
Model Number: WD
Unit Serial Number:  
Firmware Number: 1.75
Capacity: 0.00 GB
SMART Status: Not Available
Test Result: FAIL
Test Error Code: 09-Sector #0-1::Write Zeros error!
Test Time: 16:14:23, November 04, 2012
Test Option: WRITE ZEROS
Model Number: WD
Unit Serial Number:  
Firmware Number: 1.75
Capacity: 0.00 GB
SMART Status: Not Available
Test Result: COMPLETE
Test Time: 16:14:33, November 04, 2012

Additional Info.

 

Windows 7 Home Premium

Manufacturer: Hewlett-Packard Company

Processor: AMD Athlon™ II X2 250 1.60GHz

Installed memory (RAM) 4.00 GB (3.75 GB usable)

System type: 64-bit Operating System

Also, when i unplug it i hear the little noise that lets you know it’s unplugged.

When i plug it back in, it has the sane sound.

Upon opening the Computer File

it does not show the WD Hard Drive.

But i know it’s plugged in due to i’m able to test it basicly

and under Device Manager it shows as WD.

 

 

Thanks for your time and your Feedback towards this problem every bit helps!

 

 

Hi, sorry dude if the DLG test failed there is not a lot you can do, if you can still access the files, do a backup.