WD 1tb (external) Not Recognize and unreadable

Please help me. Atleast ro recover my data in the external hard drive. My wd 1tb external hard drive is not recognizing and if i do any thing to detect it  it freezes the whole thing 

the following are thing that i have done to try solved it :-

 1.) uninstalled USB ports , registries ,change usb port/cable. result : tried so many times but still not showing up.

 2.) I am using windows 7 tried to use Disk managment . result : if i open disk managment after plugin in hard disk ,it won’t open, when right click to change the drive letter it shown unmark except for delete. if i open it before and then try to locate external hard drive it freezes .  

 3.) Devce manager , if i open it and then plug in hardrive it shows the hardrive in disk drivers section and the USB controler section also have a entry named for my external hard drive it could be uninstalled (does’t matter still can’t open it)

 4.) CMD if i try to accesse it with CMD it will take some time and say “error performing inpage operation”

possible reason :

one time when i was using it  it stopped working and freezed so i directly removed the cable (" saftly remove" wasn’t working ) and thats how the whole thing started ,the only possible resone i can think of is it was set on" performence mode" and i removed it directly

Hi razlan, welcome to the WD Community. Sorry to hear you cannot access your files. Have you tried connecting the hard drive to another PC? If the problem continues the the unit would appear to be faulty, since you need to recover your files, I recommend you to contact support first before trying to do anything else.