1TB WD External Drive not being recognised by PC

Hey guys.

I tried searching through older posts about this, and there were a few helpful threads but nothing which matched my specific problem.

I’ve got a 1TB external drive (WD10EADS-00M2BO) which has around 200gb of backups on there from my PC.

It’s been working fine, up until two or three days ago, when it stopped showing up in My Computer when I plugged it in/turned it on.

Whenever I plug it in, I get the Windows “hardware inserted” kinda beep, the blue light shows up next to the USB cable, and I can also hear the disk spinning, but I cannot find it. I don’t get anything pop up giving me options, it does not show up in my computer, and no matter how many times I check for hardware changes in Device Manager I’m not seeing it.

Can anyone help me with this, as there’s a lot of stuff on the drive which is unreplaceable. Not just backups, but other personal documents which I’d put straight on there.

If there’s anyone that has a few troubleshooting techniques I can try, I’d really appreciate it.



I have the exact same problem that started about two weeks ago. :grumpycat:  

I have reformatted the USB ports and when I plugged the HDD back in, it now registers as a floppy drive-haven’t had one of those in YEARS! 

Not sure what else to do, I wonder if this is a microsoft update glitch…this drive has all of my business stuff on it, in addition, it had all of my material for my final class captsone project.  Had to re-do ALL of it.  I almost think using DVD’s to back up my data would be much better than spending money on this.  :smirk_cat:

Look and see if the drive shows in Disk Management.


Yes, the drive shows in the device manager (under “Disk Drives”). I tired to update the driver, and scan for hardware changes and nothing came up.

I uninstalled it, reinstalled it.  The “plug and play” kicks in, installs the software and driver, however, it puts it under the “A” (floppy disc) drive.  I uninstalled and tried a different USB port, same problem.  Same thing on my lap top as well.  I thought it was my computer, but am beginning to get the impression it is the harddrive itself.

Any ideas?  I would at least love to get my photographs off of it; it is still under warranty as well, have only had it for about 9 months when it quit working after Christmas. 



Did you try to download WD SES driver?