WD external HDD cannot access

Good day everyone.
I am newbie here.
Basically, I have a WD 1TB external hard drive which was working fine for the past few months.
I was trying to on it last night where it seems to be super strange to me.
My computer (Windows 7) seems can’t recognized my hard drive by showing Local Disk (E) instead of “my passport” as usual. The hard drive light is non-stop blinking.
I tried on the windows CMD by typing chkdsk E:/f/r, it cannot work at all which show nothing.
I even tried on the Data lifeguard diagnosis and ease data recovery, it takes ages to load or it properly can’t load at all.
I even tried to check it through the disk management, the result just the same as the above, takes super long time to perform.
I have many important files and pictures inside the hard drive.
Is there anything i can do on this issue?
Thank you.


Try connecting the drive to a different USB port and/or with a different USB cable.

Did you try CHKDSK /f/r? If so, that will take a long time to complete (especially on large drives). Hopefully you didn’t disconnect it while the LED was still blinking (I.e. data read / write actions).

When running /R, CHKDSK will check the entire disk surface for bad sectors and attempt once again to repair or work around any that it finds, if it can. Running /R also does /F as well.

Hi, check whether the drive is appearing on device manager if it is appearing there then do right click on the drive and select the update driver software. After updating the driver software, reconnect the drive to check whether it starts working fine.