WD Elements 1TB Not Recognizing

Hey guys, just a quick question about my hard drive. I’ve had a 1TB WD Elements for about 7 or 8 months, and it’s been working like a charm. Today, I go to plug the USB cord into my PC and the light on the back of the hard drive begins blinking incessantly. This has happened before, and after like 20 seconds it has detected the hard drive (bringing up that folder asking what I’d like to do). This time, however, nothing. It repeatedly blinked for about an hour, so I tried unplugging it and plugging it back in–still nothing. Tried moving the power source from a surge protector to the wall–still nothing. The only difference is that the usual dull white light is on when it’s unplugged–as soon as I try plugging it into my laptop, the light begins flashing nonstop. I know the hard drive isn’t dead either, because it does begin vibrating and never stops. Does anyone have any possible solutions? I have a ton of stuff on my hard drive that I’d really, really like to access. Thanks in advance.

i can only think about having the drive checked with winDLG. hopefully it will pass smart. incase that it didnt, then i suggest to have the drive recovered by a local tech. incase that it passes winDLG smart test (quick test) then i suggest doing an extended test. it will burn lots of time.

heres the link. Hope this helps.


Yeah, I can’t even get that far. It pops up in My Computer now, but when I click it nothing’s in there, and when I try to do anything it says Windows can’t access the disk.

do you mean the drive is not even detected by WinDLG? have you tried scanning it? if so, then next suggestion would be to test it using another computer