WD External Hard drive not recognized

I have a My passport 1TB External. I’m on Windows 7 x32. After I updated I’ve been getting a lot of bugs and extreme lag.  I have to restart my PC everytime so I can renter the External. I then installed all WD software from the Control Panel, didn’t change anything or help at all.

I have no clue what to do or what has happened, but my External HD is pretty much useless right now. I have very important files on there, I need to get access to this immediately.

Please help!

EDIT: Now my PC has trouble recognizing the External. I tried it on my Laptop also, it doesn’t show anything. It shows up under disk management sometimes. For example it’ll show up then simply disappear.


Computer-WD is not seen.PNG

My external HD will not appear under DISK MANAGEMENT. I don’t know if the USB cable that connects the External to my PC is bad or not? My external was working an hour before all this happened, so I don’t understand what is happening?


Disk Management.PNG


It is showing in Disc drives


**WD Issue.PNG

Also, when I click on “Devices and Printers”, an icon appears with “My passport 0730”. This is what is shows.**

My External does light up when plugged into my PC and turns off when removed. I can hear a ticking sound which sounds like the HD working? I tried to change the drive names & tried to format but there is no use.


I kindly request you help me to fix the problem asap. I have very important data in this disc and no back also. Kindly suggest me how to get rid of this issue.  

I am having a similar issue as well with my 1 TB My Passport but I use a computer that runs x64 Windows 7. I’ve only had it for about 3 months (it was a Chrismas present form my parents) and I’m getting frustrated.

When I try to access the drive through Disc Management but it is labeled as not initialized and when I try to do so, I get an I/O Device error.

Make sure you are not using a cable longer than the one supplied or connect through a hub. If the drive is still in warranty contact WD they’ll probably send you a new cable.


Tried that but still the same result. All ready contacted WD about this issue but all I got was this:

“Attachments added to case must be less than 5MB. Please note: Attachments of type .EXE will not be reviewed.”

Is this because I didn’t attach anything to my case?

EDIT: I think my drive is just dying because I ran a SMART status with WD Drive Ultilities and it said that the SMART status failed.