WD passport does not appear or is not recognized when plugged in

I bought an acer aspire p3 with windows 8 but when i plugged in my external drive, it does not appear anywhere. I’ve tried the disk manager but it only says Disk 0, which i think is the main drive in the laptop, or am i wrong? :stuck_out_tongue: it worked just fine with my 2 TB WD TV live (i think that’s what it’s called). I encountered this link http://community.wd.com/t5/External-Drives-for-PC/Simple-fix-for-quot-USB-device-not-recognized-quot/td-p/165404 , and it worked like magic last night but when i tried it again this morning, the external drive is not recognized again. There are no dialogue boxes that tells me what is wrong. When i plug the external drive, the light turns on but nothing happens. Please help. :((

Hello mightykaxe, be sure to use the USB cable that came bundled with the Passport or one of the same length, longer cables can cause power inconsistencies, also avoid using USB extension cables or USB hubs.

1 Like

Yeah, that’s the one i’m using. I asked the store where i bought my laptop and they said that there may be too many files or there’s a virus in my passport and the computer takes a long time to read or sometimes refuse to read the passport. ( is that a possible cause? ) I’ve taken their advice to format the passport after transferring my files to a back-up. The laptop now reads the passport sometimes and I think it is a problem with the cable. And I’ve noticed that the computer reads the passport at a certain position of the cable. I think the usb port and the cable is not exactly fit for each other in the sense that a little bit of the metal thing is sticking out and not fully inserted to the port (or is that normal and I’m just really stupid about these things? Well anyway that’s just my observation :p). I’ll try to go to the WD store and try if a new cable would solve this problem (and i just formatted my drive for nothing *o* ) thank you for giving your time to answer my question, it might not have been the answer but it gave me an idea of what could be the problem :slight_smile: I’ll try my best to post if what I’ve concluded did solve my problem. If you have any input or suggestion to what could be the other sources of my dilemma based on this very long post (sorry!), feel free to reply. I will appreciate every help I can get. THANK YOU!!!

Hi again, yes, a virus or having corrupted files saved in the Passport can cause difficulties for the PC to read it. Another possibility is that your laptop is not providing enough energy to make the Passport work correctly, since some laptops don’t provide full power to all USB ports when they are not connected to a power source, you can check the laptop manual to verify this. Try using another USB port on the laptop to connect the Passport or you can also connect the Passport to a desktop PC to see if the same problem continues. A faulty USB cable can also be causing the problem, you can also call/Email tech support directly to get a replacement.


1 Like