My Passport 1TB isn't recognized, not even in disk management

Hey, I posted this earlier to another topic but there was no response so I decided to start a new one.

So the My Passport drive is no longer recognized by any PC, I have tried 4 different PC:s now with multiple USB ports. I have tried the common troubleshooting procedures: there’s no device connection sound from Windows, different USB ports do not help, and the drive doesn’t show up anywhere at the PC. It doesn’t show up at the disk management either. All what happens is My Passport light goes on and it starts running.

The problem started when I tried to connect the drive to a friend’s computer, through a USB hub which was not working. After that, the drive hasn’t been recognized in anywhere. Don’t know if it is possible that an USB hub could damage the drive but that’s when this started.

The sound the drive produces is normal, it starts whirring and clicks a few times but nothing happens. So, is it dead?


I recommend that you try on a desktop computer connected to the back ports and use a different USB cord if possible. If it is still not working then it means the drive has died and needs to be replaced.

If the drive is still under warranty then you can create a RMA and have your drive replaced.

How to get an RMA, (Return Merchandise Authorization) or replace a defective product under warranty 

I also have similar problem.  my PC no longer recognizes my WD Passport Ultra.  It may be damged.  How can I recover files?

I really need help!!!

hi, I am also facing the same issue my ultra is not getting recognised anywhere Disk management shows the drive is not initialised Does it mean my HD is Dead , please throw some light Thanks, SAi