WD My Passport recognition issue

Hello,
The WD My Passport external hard drive has worked on all my past computers. I have a new PC and it simply does not show up when I attach it. I have tried some simple solutions, but to now avail.
I would imagine there is a solution, but I’m not too savvy with advanced computer diagnostics.
This seems to be a common problem, as there are several youtube videos addressing this issue. I am at a loss. Can someone help me?

Did you check your drive on Disk management on windows???

  • check its showing up there or not .

  • if on disk management , it gives any pop up to initialize the disk “DO NOT INITIALIZE IT” : initializing the disk will format the drive and you might lose the data .

  • if the disk showing up there on disk management : and disk status is healthy then try assigning a different drive letter to the drive.

  • if still issue same contact WD support

Hello Shaw.Patrick,

 All the simple solutions are not working.  WD support is nonexistant. I'll bet someone who knew what they were doing would be able to rectify this situation in a matter of minutes. I've watched a few videos that offer quick solutions, but they fall short of completing the task and want you to pay for their expertise.

Frustrated,
Ang7

Yeah I had the same issue. I was using a legacy My Book on Windows 7 just fine. I just recently upgraded to Windows 10 and my computer is now unable to recognize the drive. My Book doesn’t show up on file explorer or disk management.

I’ve tried to install the legacy WD SES Driver setup for x64, but that didn’t work either. I did all the basic troubleshooting for power and changing to a shorter cable. Switching to a usb 2.0 cable. None of that woked.

Any help would be appreciated.