WD EX4100 tijmes out before it can open a share

We have a MyCloud EX4100 that we’ve used for storage for a number of years. We have a lot of data in small files on the drive. The main share now has so many files it takes quite a while to determine the amount of storage used in the directory (if I ssh into the device and use a du command, it takes more than 15 minutes to finish). The downside of this is that that web interface checks the usage whenever you click on a share (to change permissions or sharing services, etc) and the interface times out after 10 or 15 minutes. This seems to means that once you fill a share beyond a certain number of files (making it take more than the interface timeout to check the usage), you can no longer edit the share settings using the web interface. Am I misunderstanding the situation? Is there a workaround (other than ssh’ing into the device and temporarily moving the files out of the share and then using the web interface to edit settings)? I have tested, and moving the files out before using the Share settings on the web interface does work, it just seems odd if it’s necessary.

Andrew Lundberg

Workaround for one case of login session time:

First, just so the context of the problem comes first, what comes second is actually more significant for all customers:

Using a WD My Cloud Mirror (Gen 2), firmware 2.31.204. When I login to the web interface, navigate to “Shares”, and select a large and well populated share, out of 5 shares, the web interface virtually freezes. That’s the context of the problem. The each time solution is to login using ssh (requires setup) and kill the process running “du -sh” on the selected share.

The actual problem is that WD (unforgivably like so many other software giants holding us hostage) does nothing in cases like this to help the user community. Their tech support has a cumbersome protocol that resets the device and we never get back to the real problem. They close the case as if it were solved and the real problem is never resolved. HOW TO FIX THIS PROBLEM: Don’t let tech support close your ticket until the problem is actually solved.

I’d use another vendor, but they all seem the same in this matter.

The EX4100 does not have enough power to process your data set.
The solution is to move the data to higher performance NAS or build your own high performance Linux server with high performance disk and less overhead.

Else, you can disable Remote Access, Twonky, iTunes Server and anything else that consume resources, reboot and try.