EX4 Creating Hundreds of shares on its own

Hey all, Im kind of in a rough spot now and figured I would post my situation here to see if I can find like issues as my google-foo has ran out.

I currently have an EX4, I have tried to submit my issue via the WD channels however, either they are understaffed or ignorant towards users issues.

Specs:
EX4
WDMyCloudEX4 Firmware Version: 2.11.157.1110.2016
4x WD Red 4TB drives

Issue:
CPU spikes to 100% however its not a single process consuming all the CPU. During this spike in activity I noticed that there is a loop, or something that is creating multiple shares. When I mean multiple I mean upwards to a 1k

root@NASAMS001 /shares # ls -1 | wc -l
1029

All in sequential order. Public_###

Troubleshooting:
-Transfered the jbod disk with my data off the NAS and do a full restore. The issue was persistent before the restore, and is still persistent after.
-Removed all disks and used a single disk to test. Still had multiple shares.
-Manually deleted the shares through samba and such. Problem came back shortly after.
-Reboot
-Cold Reboot

This was also persistent through firmware 2.11.157 and 2.11.153.

Is there anyone else out there waking up in the morning and finding 1k public shares being crapped out by their nas?

If your unit behaves the same even after a full factory restore then it may need to be replaced. You can request a free replacement in the following link:

Also, if you’re using any extensive SSH to modify the drive, support won’t provide support for that. The full factory restore, Trancer is recommending, should fix any SSH issues.

Make sure that you have your data backed up before, because the full restore will wipe everything. And, finally, if you had a lot of files on the drive before, it could have been still indexing them. For large amounts of files, indexing could take quite a while and it could user large quantities of CPU.

Yes, exactly the same issue. Weeks in the support queue. Getting nowhere

I’m more annoyed with the guy trying to help with SSH issues when there is nothing close to that in my subject or even mentioned.

Then he goes on to talk about indexing…yes, over one thousand public shares is related to data indexing…https://i.imgur.com/RhU6aXy.jpg

It seemed to all start when I rebooted the device

EX4100 +3 Logged into the device today to find hundreds of Public / SmartWare / TimeMachine directories. Updated to current firm weeks ago. Always bites me… but heard security probs. Tried to delete directories, no joy. Did 4 second reset, no joy. Did 40 second reset, no joy. Did a system reset, no joy. Did a full reset, no joy In process of doing factory reset…

Did anyone else get this resolved as I see its been out there a while…

Does this thread sound like your issue?


or

Heed my advice.
RMA the unit
When the new unit comes in rebuild with only use freshly wiped drives.
Huge PIA,

The one good thing that came out of this is that I now have a backup strategy for my NAS and can recover if the NAS shits the bed again.

@Bill_S Bill_S

Now my second unit is doing it… RMA is not the answer unless this is a HW problem. It seems more firmware as these have been behaving “normally” until recent FW update. Weird that not immediate after update. And 1 goes down, now 2. (same weird delay) (I usually upgrade 1, then wait 24hrs on the other to make sure no critical bugs.) Also looks like this is effecting EX4 and 4100s alike.

I cannot afford the luxury of doing the same procedure on the 2nd unit. I need escalation again from WD.

FYI - I fixed 1 by exactly full reset with a fresh drive. This is not acceptable. Im not using SSH, any advanced function nor are they web facing. Only basic internal file servers.

Bill, you may recall I had some engineering issues with my old EX4s, I paid to upgrade to EX4100 and had some DOA out of the box. Now this… Its getting old. I need escalation
And * My email is no longer valid on this forum, but I cannot find where to change it. PM me for current address if you need to update it manually.

I’m having you escalated. Private message me your old and new email addresses, and I’ll get it updated.

Sorry, been a busy week. Sent PM with updated email.

Update for the rest. Another observation is that I am currently sitting at only 4 duplicates of mentioned files. If I recall it only exploded to hundreds after I tried to delete one on the first device. ADVICE: Dont try to delete the extras. So im not until I talk to L3 again. Ill post an update here when I resumed TS and have more to share.

Also note I have pulled all drives but root / bay 1 to prevent corruption.

@Bill_S

Been limping along crippled using only 1 drive at a time in 2 4 bay units and now finally locked me out of devices… trying to create a new user.

My old EX4Shot UID is also locked because of your 2017 forum reset and I cannot reset the PW since email is no good.

Bill can you Jim contact me again at the contact info in EX4Shot and merge these two accts? I really need to get these running by weekend…

Hi spankpaddle ,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support

Same issue here. It was working fine for years until I created a new share then all of the sudden I have 900 public shares.

No idea how to fix

I was wondering if I was just the only one who had this problem.

What to do now?

There is no way to fix this. The only way I was able to get rid of it was to:
RMA the unit
!FORMAT! all old drives !BEFORE! putting them into the new unit.

Mine issue was triggered by a firmware upgrade. So, to say the least, I used to be very hesitant to do any upgrades.

Now, I have a solid backup plan for the NAS so that I can recover if I have to reset it.

Did you ever get this resolved ??

Cheers

Michael

I was wondering if there is a fix for this as It is happening to me !!

Cheers Michael