WD Elements - USB Device Not Recognised - The USB set address request failed

I am running Windows 10 Pro 64 bit. I have two external WD Drives (and some others) and I keep getting this error message for my WD Elements 5TB drive

When I check Device Manager I see, under USBs, the yellow triangle with the exclamation mark in and the message “Uknown USB Device (Set Address Failed)”

When I click on Properties I get this

I have searched and tried all the usual suspects:-

1 updated driver
2 disabled that USB port, restarted pc and allowed Windows to update driver
3 swapped drive to another PC (it seemed to work but, maybe, I didn’t leave it connected long enough as it can take several days before “disconnecting” and the error message appearing)
4 switched to another USB port (it is not a hub, by the way)
5 switched power cables with another WD drive
6 switched USB cables with another WD drive
7 ran the WD Lifeguard Diagnostic program and drive was healthy no issues
8 safely ejected drive from pc, disconnected power from drive, turned off pc, disconnected power from pc, then reversed that process - see HERE.

The latter seemed to fix it and lasted about a week and then, today, up popped the error message again at the top of this post.

Has anyone experienced this issue and managed to solve this?

1 Like

I have not seen this issue before in the WD Community.

How did you test your hard drive using WD Data Lifeguard Diagnostics? On Windows 10 64-bit you’ll have to right-click the app and select “run as administrator” so it can properly test your hard drive even if you are using an admin account.

Thanks for your reply. I’m not sure whether I did “run as administrator” so I have just re-run it that way. The "Quick Test results were fine.

I am now running the extended test but that is a long process - circa 8 hours (5TB). I will post the results when finished.

In the meantime, possibly the Event Viewer will give a clue. I am limited to 2 images per post so will add them on the next post.

The Event Viewer shows this for the Error

and shows this for the Information

Does that provide any clues to what may be the problem? Thanks in advance.

1 Like

…and it passed the extended test as well

Hi, I seem to be having the same issue with my 2TB WD Drive, did you find a way to fix it or atleast recover the files?

1 Like

Hi. I’m away on holiday for nearly four weeks but I seemed to have fixed it before I left but can’t be sure until I get home and see if the drive is still being recognised.

I used a piece of software called, I think, cleanupdisk.exe. Basically, you disconnect everything from all the USB ports (except the mouse) and run the program. On the forum I found the solution it said you will see the message fault found and corrected (or similar) but that didn’t happen for me! Then switch off (not restart) the PC. Switch back on. Then reconnect all the USB drives, etc.

The operating system found l’ll the drivers including the previously unrecognised drive. It did a bit of re-lettering exercise back to my original set-up so watch for that.

As I said, because I’m away I don’t know if that fixed it perfectly but it looked promising.

Let me know how it goes.

1 Like

Unfortunately, it lasted 6 weeks but has just failed again. Can anyone help?

I had exactly this problem this morning. My WD Elements is only roughly 2 months old since I bought it. And now it is showing me the exact same message you wrote above. USB not recognized and Device Adress Failed. I think it is high time the system developers come out in the open and explain to us what we need to do. It is not funny at all. These Passports are expensive and we have saved important data that we need to access at a later time. My entire Data for my research is there. If the probability of losing this data is this high, then why have the WD Elements in the market in the first place? This is not funny. Whether it’s from impact or system failure, we need to know the remedy. One of the folders I had in the external hard disk was a 30-day trial software. That does mean we need a new software or what? If yes. which one? IT Experts from this company, WE NEED HELP!!!

1 Like

I tried several more possible solutions but none succeeded for long. I eventually bought a new replacement Seagate drive (THIS) and connected the WD to another PC running Windows 7 64 bit Home Premium. It is running fine on that and so, the problem must be related to my main PC running Windows 10 64 bit Professional. However, having tried fully uninstalling and disabling and clearing registries etc. I’m not sure what else I could have tried. Any ideas?

1 Like

I have been following all the suggestions to fix this incompatibility between Western Digital portable hard drive. and HP computers.
Could it be a Firewall or Virus Protection Software issue?

Mine isn’t an HP computer but thanks for the suggestion. I am unsure how the Firewall or Virus Protection could affect one WD drive but not another (I also have an external drive - a WD My Book 2Gb one attached) That is not affected.

Hi Clive_Harding ,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support

Thanks!

Thanks Peter. I’ll do that (and thank you for taking the trouble to provide the link - much appreciated) and report back the outcome, good or bad.

Hi Clive_Harding ,

Thanks for the feedback.

I have the same problem since about a month with my WD Elements 5TB. Did you have any luck yet?

I’m afraid I eventually gave up. It would work OK for a week or so then I’d get the same error message. It is NOT caused by the disk drive in isolation because I have been using it on my 2nd PC for the past 5 months without ever getting the error. So it is a PC-generated issue but I have no idea what. Let me know if you ever track the cause down.

To everyone having this issue, I’ve had both this and the port reset failed error using my drive on my laptop using Windows 10. What worked for me without failing again is to connect it to a hub USB port on a dock/break out box (which yes everything says not to do) OR put an extension USB cord between your computer and the SS/3.0 USB that connects to the actual external drive.

Is data transfer speed slower? Yes, slightly - but you can at least view your files again and your machine will recognize the drive. Spent countless hours with the computer manufacturer and researching online and this just worked one day. Had same problem with my wife’s computer also running Windows 10 and worked on hers as well. It’s been a few months with no problems. Hoping this helps anyone having this issue potentially.

Oh my goodness, I am totally in over my head, but Channa676, would you help a poor low-tech person out and tell me if an extension USB cord is something I can get at, like, Target? :confused::woozy_face

I’ve been a total basketcase this last week since my my 4TB WD hard drive stopped playing nicely with my computer or my laptop. It all started when I got a new monitor, so I had unplugged all my computer stuff - didn’t move any of it any more than necessary to unplug - then put in the monitor and plugged everything back in and suddenly windows gave me the exact message that they gave Clive, which he shows at the top of this chain.

The drive goes on, it makes the humming like it always did, but I can’t get in there. and all of my course work and I don’t even know exactly which files, but SO many are on there. I mean, it wasn’t even 1 TB used, but it was all of my stuff!!

WD wants to send me a new hard drive but they don’t do data recovery they said, so I’m SOL. They sent me over to datarecovery.com for a quote and they quoted me $750!!! It’s $100 just for them to look at it! I only paid $80 for this about a year ago! I’m so afraid I’m just going to have to say goodbye to whatever is on here because there is no way I can afford $750.

I don’t mean to dump on you, but I’ve been looking around for another option and this is the closest I’ve come to finding something hopeful. I really would appreciate any help you can give me, even just a point in a more reasonably priced direction.

Thank you!!!
Kerissa

Hi there-sure. Here is a link to one. Just use connect this to your computer and then the hardrive to the end of the extension usb. Hope it works!

AmazonBasics USB 3.0 Extension Cable - A-Male to A-Female - 6.5 Feet (2 meters)

Cheers!