WD Elements SE Not Responding

Hi all, anybody experiencing their WD Elements SE drive suddenly not working?

I’m running on M1 iMac OS 12.3.1 and the drive is flashing white but not mounting on the desktop or MacBook.

I’ve tried to access using disk utility and by using the WD Drive Utilities but again its showing up in these programmes but no access to the drive.

Any thoughts or suggestions on a fix?

Thanks in advance.


Hi @dsupreme,

Please follow these steps to resolve the issue:

Mount a volume that’s been ejected using Disk Utility on Mac

In case you already have tried that and failed, you can also check the device’s health using WD Dashboard.

Find instructions on the matter here:Install Western Digital Dashboard for Drive Performance Monitoring

If you have used the drive on a Windows system before/you are using it for the first time on your Mac, there is a chance that your drive needs to be reformatted to the correct MacOs-supported file system. You can do so by following the steps below:

Reformatting required for Mac OS Compatibility:

Before doing that I would advise you to connect the drive to another computer to back up your data as reformatting the drive is data destructive.