Help - WD Elements SE not mounting

Hi guys,

I recently purchased a WD Elements SE 750GB EHD. The unit has 2 days of use. I am running a 15 MBP 2.4GHz Intel Core 2 Duo 2 GB.

I partionited the drive to be Mac compiiant and transferred approximately 450GB of personal media to the drive. It worked perfectly fine on day one. After heading to bed, the following day the drive will not mount, it isn’t being found in disk utility and it isn’t being found in the USB drives. The drive turns on and the light display flashes with the spinning sound occuring.

I have another WD Elements drive and a Seagate. Both work fine. I’ve tried using the different USB connection all to no avail.

Can someone help as I’m majorly pissed off right now?

Thanks in advance.

Hi there, do you have another computer (If it’s a desktop even better) or a booster “Y” USB cable?

Is the data is still in your computer? If so then replace the drive, if not… Try and see if a data recovery software like TestDisk is able to see the drive on a low level.

You can also try and see if the drive is not seen on Windows as well since it will allow you to use WD’s DLG to test it…


I tried all the work arounds suggested on the forum in other threads. Different computers, operating systems, USB cables etc. Nothing was working. I returned the item and received a full refund. We’ll see how the Seagate performs.

Thanks for your help.