WD Element is off on TV / HDMI


#1

Hello
All I am new to this forum.
I have the following problem recently bought a 1TB WD Elements play, I foragedfor snow leopard mac-as indicated by the WD website.
After several problems wd change my new one, going 3 and
The problem is that it connected via hdmi to my Panasonic TX P42G20 tv andnot see anything, from WD told me I had to do with an HDMI 1.4 cable which buysoon.
It turns out that buying the cable and connecting to the tv hdmi slot in 1.4 (HDMI 2 (ACR)) can not see anything.
I tried the cable through my blu ray and connecting the tv and it looks good so theproblem is not the cable or the tv.
But if I plug the RCA cables if you can see my menu and contents, thendisconnect the rca and maintained by the hdmi, but if I disconnect the player and turn it after a while does not work.
Any solution to the problem, if the format type is wrong? the WD elements I have changed 3 times, the cables are fine, TV slots are also ok .???.
I have the latest firmware version 1.01.10
Since WD does not give me a solution, so I am very unhappy with this product.

Best regard to Spain.


#2

Did you fix this issue? Are you able to use the Element with your TV?


#3

I have the same problem, the HDMI is not working, have you solved the problem yet?


#4

SAme problem here…any help?

at least say its a problem with WD so we can move on…


#5

What brand/model of tv do you all use?  Two people here seem to have a problem with a Panasonic TV.  

If it works via the composite connection (yellow red and white phonos) and then carries on working if you switch to HDMI, it seems the TV or EP is not recognising the other via HDMI? Ids the HMI setting on Auto? 

The person who can’t upgrade because they can’t see the menus could use composite for the upgrade and then see if that sorts it.


#6

Hi axs23,

The solution is in my post:

http://community.wdc.com/t5/WD-Elements-Play/Solution-to-Panasonic-HDTV-HDMI-Problem/td-p/147242