WD Drive Unlock - Upgrade / Removal


I have a WD My Passport 1TB USB 3.0 portable drive (Model - WDBBEP0010BBK-03) and it comes with an old and outdated program for the drive security called WD DriveUnlock instead of WD Smartware. I tried to upgrade the WD Drive Unlock program as its old and has issues but to no avail. I tried to download all the update / updaters in the given sequence and run them but it still did not upgrade the WD Drive Unlock. In the process I ended up installing the latest version of WD Smartware software on my computer, which recognizes the drive and can help unlock it but does not have the drive setup option for the drive. I need to get the WD Drive Unlocker updated as the program does not have the cursor blinking at the password entering screen by default and makes me click on  it (which i feel is an additional step) to enter the password. Please guide me to upgrade it to WD Smartware (which I know is better) or help me get rid of this.



You can try downloading the WD Drive Utilities  and also the WD Security software from the link below:


If you still not able to make them work then I recommend you contact support for assistance.

Contact WD

Thank you for the reply. Will do that and letyou know.

Hi Hamlet,

I opened the URL that you shared and found it to be the exact same one that I used to download the latest WD Software / Driver for my drive. As mentioned in my original post, I did go through each Software / Driver update link on the page for my Dirve and found the following hurdles.

  1. First I installed " WD Universal Firmware Updater for Windows" and installed it as per  the direction.

  2. Then I went inside " WD SES Driver" and installed the latest SES Drivers (WD SES Driver (64-bit)). In the same folder, there is another like / update “WD SmartWare Disk Image for Windows” which I’ve downloaded and when I try to run it as instructed in the page, I run into some problem. So they ask me to copy the downloaded file / folders to the external drive which is drive F: on my computer. Then when I run the WD Smartware as instructed in the instructions, it throws up an error msg.

Please guide me how to get it installed and what to do next.