Passport Essential 1TB

I have seen a couple of threads and I have seen a couple of answers but I’m still really disappointed that nothing has worked for me yet. I have a WD Passport Essential 1TB drive that the Unlocker software no longer works correctly.

  1. I’ve tried initializing the drive the disk manager and it says it is write protected in Vista, and just refuses to do anything in Windows 10.1.

Everything was working fine until the upgrade to Windows 8. The pop-up that I’m getting reads as follows, "You must run the Unlock application from the WD SmartWare CD associated with the drive you want to unlock. Click Exit, Locate and open the related WD SmartWare CD, and then run Unlock to unlock the desired drive. Has any one found any solutions to this issue.

Hii there,

Have you tried on a windows 7 computer to see if you can disable the password protection and then use it on your computer?

Tried going back to Vista and it actually gave me the same error message. I’m actually really perplexed now. The WD Smartware partition is recognized no problem on every computer I plug it into, but I can’t get the WD Unlocker to work still. Any reason Win 7 might act differently?