WD Dashboard on Windows 11 not working

Hi,

WD Dashboard on Windows 11 is not working. I am using WD SN850 M.2 NVME and WD Blue SATA HDD. No information is being displayed.

Hi @rajiviyer - please make sure you are using NVMe driver for the SN850. The interface shown indicates the drive is being detected as SCSI.

Another user was successful doing this in a similar case.

Hi,
I am using the driver selected by windows. When I try to update the driver, it says “already using the best one”. I am not using any SCSI mode. On Windows 10 it was working fine. After moving to Windows 11, its not working.

I uninstalled the disk drives from Device Manager and rebooted the computer. It still shows as the image above.

You see the device is “{Model Number} SCSI Disk Device”. The “SCSI Disk Device” part is telling you that it is actually being surfaced as a SCSI device by the OS storage stack. That imposes a lot of limitations on software like Dashboard.

I don’t have Windows 11 on my PC, but here is a sample for how it looks on my PC running Windows 10. If I view by connection in device manager I see the drive sitting underneath the Standard NVM Express Controller.

I recommend reaching out to Microsoft support for help to install the proper driver to have at least your NVMe SSD on the M.2 port show up as NVMe. Recently some updates have introduced some issues with NVMe storage drivers on AMD, maybe you are affected by something similar.

I am using AMD Ryzen 5800X CPU. I had installed AMD StoreMI utility. I guess, the utility was treating the disk as a SCSI attached to a SCSI controller & not NVMe.

After uninstalling the utility, the dashboard works fine.