WD Caviar Green I/O errors/bad sectors?

Dear Western Digital Community,

On the 21st of april 2015 I bought a Western digital / Caviar Green 2TB WD20EZRX through an online retailer called afuture.nl After a month or 2, I started having problems when copying files from/to the hard drive. Also, suddenly a download stopped and gave an I/O disk error.

I started to back up my files, but some files in some folders couldnt be copied, so I lost some data. I ran WD Digital Data Lifeguard Diagnostics on it, the Quick Test failed and it said 'Status code = 07 (failed read test element), Failure Checkpoint = 97 (Unknown Test) Smart self-test did not complete. I did some searching on the web and on forums, and it seems like this disk is afflicted by bad sectors. (?)

So earlier today I tried to register my product for warranty, but it gave me this message: 0 product(s) were registered out of 1. The following asset(s) failed to register: because it’s either an OEM product or the warranty has been voided. For further assistance, please contact the WD support team [[DELETED]]

When I tried to create new support case, it said: “An error was encountered during knowledge base search.”
EDIT: I tried this again, and it seems I can’t make a new support case because I couldn’t register my product :frowning:
So I came here, hoping someone could shed some light or help out.

So the questions are: what’s wrong with my HDD, can it by replaced by WD? (the after-purchase service of afuture.nl is realy slow so I thought I’d just check with WD), why can’t my product be registered? And if it can be replaced, is it gonna cost me anything (like costs of sending the HDD to WD)?

Thanks in advance

Welcome to the Community.

Have you tried calling WD about this? Their support website was recently overhauled, so it may be possible to report some errors until the platform becomes more stable.

To Contact WD for Technical Support

They will be able to process a replacement order for your unit as long as it remains under warranty.